Eigrp redistribution problem

Unanswered Question
Jun 10th, 2008

Dear all,

There are two branch offices of a customer connected to a PE router. One of this link(CPE1) use EIGRP as PE-CE protocol and the other one(CPE2) use STATIC.

I have attached a diagram to get a clear idea.

I have redistributed the EIGRP routes to MP BGP and vice versa. Similarly STATIC routes are redistributed to MP BGP and vice versa.

Will the static routing entry (Network X) be advertised to the CPE1 router?

or do i need to put redistribute static inside the eigrp address family to send the Network X entry to CPE1?

I have checked it, i need that redistribution of static route into Eigrp address-family. But i feel there may be any problem. Please advice me.

jayanthan.T

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
lee.reade Tue, 06/10/2008 - 03:36

Hi,

As long as you have redistributed eigrp into MPBGP onsite site 1 (vlan100) and have redistributed static into MPBGP on site 2 (vlan200), this will create the VPNV4 router on the PE.

All you will need to do now, is make sure that the VRF for site 1 imports the routes that the VRF for site 2 exports, and vice versa.

For example;

ip vrf vlan100

rd 100:100

route-target export 100:100

route-target import 100:200

ip vrf vlan200

rd 100:200

route-target export 100:200

route-target import 100:100

Then under the address family for eigrp for site 1 vlan100 vrf, redistrbute bgp in.

For site 2 vlan200, you will need either a default route on the CE, or a static route to site 1 vlan 100 networks.

Hope this helps.

Cheers

LR

jayanthan Tue, 06/10/2008 - 04:50

Thanks for the response LR,

This two links belons to the same customer.

ip vrf MTN

description ***MTN***

rd 65500:1013001

route-target export 65500:1013001

route-target import 65500:1013001

!

### eigrp interface ###

interface GigabitEthernet0/1.41

description *** DTL IT UNIONPLACE 48Mbps***

encapsulation dot1Q 41

ip vrf forwarding MTN

ip address 192.168.29.2 255.255.255.252

no cdp enable

end

### Static Interface ###

interface GigabitEthernet0/1.269

description *** MTN SOFT LOGIC - WELLAWATTA COL 06 ***

encapsulation dot1Q 269

ip vrf forwarding MTN

ip address 10.1.0.118 255.255.255.252

service-policy output 512K

no cdp enable

end

### Static route ###

ip route vrf MTN 172.21.204.160 255.255.255.240 10.1.0.117

### EIGRP CONF ###

router eigrp 1

address-family ipv4 vrf MTN

redistribute bgp 65500 metric 128 1900 255 1 1500

network 192.168.29.0 0.0.0.3

no auto-summary

autonomous-system 200

exit-address-family

!

### BGP CONF ###

router bgp 65500

address-family ipv4 vrf MTN

redistribute connected

redistribute static

redistribute eigrp 200

default-information originate

no auto-summary

no synchronization

exit-address-family

!

Do i need to add the following command eigrp address family to send the route to CPE1?

router eigrp 1

address-family ipv4 vrf MTN

redistribute static metric 128 1000 100 1 1500

Regds,

Jaya.

lee.reade Tue, 06/10/2008 - 05:14

From what you have posted, it should be getting redistributed already, static-bgp-bgp-eigrp.

I have not tried this kind of setup before, so I would suggest that you try to redistribute the static into the eigrp address family direct, as you have mentioned above.

Can you post from the PE, the following;

show ip bgp vpn all

show ip eigrp 200 topology

Cheers

LR

jander2008 Tue, 06/10/2008 - 07:56

Hi Jaya:

Yes, you need to redistribute static under eigrp config too (even though you have it under BGP).

If you run more than one PE-CE protocol on the same PE that connects the 2 CE's you have to redistribute the routing protocol b/w them in addition to under BGP.

Same goes if you were running RIP or OSPF on one PE-CE link.

You have to redistribute RIP/OSPF into BGP + EIGRP and vice-versa.

Hope this helps.

Best Regards.

JD

jayanthan Tue, 06/10/2008 - 08:25

Hi JD and LR,

I think JD is correct. I also have tested and without redistributing static into eigrp it does not work.

I also expect to receive the route in the following way.

Static --> MP Bgp --> eigrp

It does not work.

We need to have

Static -->

MP BGP

EIGRP -->

and

STATIC --> EIGRP

Thanks

bye.

Rgds,

jaya.

waleed_amer Tue, 06/10/2008 - 09:59

Hi,

1-static --> bgp you will get the route in bgp table but will not be selected in the vrf routing table so it will not get through bgp-eigrp so you have to redistribute static into eigrp.

2-if you don't have branches connected to another PE so no need to redistribute routes into MP-BGP.

Regards,W.Amer

jayanthan Tue, 06/10/2008 - 10:32

Now i got the idea.

Not the routes in the bgp vpnv4 vrf table are redistributed into eigrp.

But the BGP routes in the vrf routing table are redistributed into eigrp.

am i correct?

thanks.

Rgds,

jaya

waleed_amer Tue, 06/10/2008 - 10:41

yes the route has to be selected and installed into the global or vrf routing table to be redistributed.

Regards,W.Amer

Actions

This Discussion