LMS 2.6 / Campus : SSH dialog box does not open on solaris

Unanswered Question
Jun 10th, 2008


Customer has LMS 2.6 on solaris. On Campus, SSH menu doesn't work, telnet menu works.

When he uses IE from a pc telnet and ssh work both, he has customize java to use putty.

Is there a way to have logs ?

Many thanks,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Tue, 06/10/2008 - 08:35

Any error will be written to the Java Plug-in console. Make sure the proper plug-in version is being used, and that the CMSSH variable is properly defined in the plug-in control panel.

ebezombes Tue, 06/10/2008 - 10:33

Java plugin is 1.4.2_08 on solaris.

In the help on line I have seen that for windows we need to define CMSSH variable but for solaris it doesn't talk about this variable.

How can I define this variable on solaris box ?

Joe Clarke Tue, 06/10/2008 - 10:52

Launch JPI_HOME/bin/ControlPanel, and set the CMSSH variable in the advanced tab just as you would on Windows.

ebezombes Wed, 06/11/2008 - 06:15

We have defined CMSSH variable and click on apply. If we launch ControlPanel, modification is not made. We are using root account.

Joe Clarke Wed, 06/11/2008 - 10:18

I don't follow. Exactly what did you do, and what results did you get?

ebezombes Wed, 06/11/2008 - 12:01

Customer has defined the parameter in the controlPanel like you have described.

But, it doesn't work anyway.

So the customer has launched an other time the controlPanel and he saw that the modification made was not effective.

He has tried to modify the parameter an other time but it is always no effective.

He was root when he has defined the parameter in the controlPanel.

Joe Clarke Wed, 06/11/2008 - 12:07

I'm so use to dealing with Windows clients, I forget that Solaris is completely different. Sorry, you don't need to set CMSSH at all if you're using a Solaris client. For Solaris, Campus will launch the following command to establish an SSH connection to the device:

xterm -e ssh [email protected]

So, make sure the Solaris client has both xterm and ssh in the PATH of the user which is running Firefox.

Joe Clarke Thu, 06/12/2008 - 07:02

On my Solaris 10 system, ssh is in /bin and xterm is in /usr/openwin/bin. So my PATH must contain:


You should also check the Java Plug-in console for errors after trying to launch SSH.

ebezombes Wed, 07/30/2008 - 00:03

You will find the PATH, which is very long.

which ssh -> /usr/local/bin/ssh.

/usr/local/bin is present in PATH.

ebezombes Wed, 10/01/2008 - 06:03

In fact, a variable was missing in deployment.properties file:


Now it works !


This Discussion