Unity Languages

Unanswered Question
Jun 10th, 2008
User Badges:

Hi,


I have just installed Unity 4.2 and when you try to enroll new users or collect your VM you start with English (United Kingdom)then half way through enrollment is goes into English (United States). The (United States) file has been moved into the Available folder and all Call Handlers settings are for (UK).


All the Subscribers on the system are using the inherited Language ( l believe this means that it uses the default from the Configuration, Phone Language)


Can some one let me know if this is correct and if anyone has come across this before?


Regards,

James

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jaime Valencia Tue, 06/10/2008 - 09:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

inherited means that if all the previous 'parts' that handled the call are set to inherited are set to inherited, then the default language will be used. if in the middle process you set one to either UK or USA english then all the next elements that handle the call will use that language. u sure there is not an element that has hardcoded a language?


HTH


javalenc


if this helps, please rate

JAMES WEST Tue, 06/10/2008 - 10:26
User Badges:

Javalenc,


Thanks for getting back to me on this.


Just to go over the point you made -


The system was built using the OS disc's that came with the Unity server (English USA) we then added the language English UK. Does this mean that using inherited being built with OS disc's (USA) you should get the welcome greeting in (USA)? I could understand this, but why is there a mix of both USA & UK?


Can you let me know where l would be able to carry out any checks other than the ones l have carried out?


Regards,

James

Jaime Valencia Tue, 06/10/2008 - 10:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

the default should be USA during the unity install, but you can change the default language for unity to UK if needed.

then all the inherited elements if not changed by other thing should be presented in UK


HTH


javalenc


if this helps, please rate

JAMES WEST Tue, 06/10/2008 - 10:47
User Badges:

Thanks, thats what l thought.


Any reason why the you would get half UK and half USA? Is there anything l can check out or do you think that l would be better logging a TAC case?


James

Jaime Valencia Tue, 06/10/2008 - 10:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

other than follow the call flow and make sure that all is set to inherited to double check, the next step would be to look at some traces and the port status monitor but i guess TAC can help you on that


HTH


javalenc


if this helps, please rate

JAMES WEST Tue, 06/10/2008 - 11:19
User Badges:

Thanks javalenc,


I will check it out next time l am on line for the customer.


Thanks for your help.


James

richb1971 Thu, 06/12/2008 - 07:45
User Badges:

James,


I've got this too. Any joy on a fix?


Rich

JAMES WEST Fri, 06/13/2008 - 01:02
User Badges:

Rich,


Unfortunately not, the info on the above forum does not point to anything definitive, so it looks like a TAC case may have to be raised.


Do you have the English UK as your default language and the US in the associated panel? If you do and everything else is using inherited, you may have to log a TAC case as well.


I have not been able to fnd anything on the forums or CCO that indicates a problem if you have it set-up as discribed above.


If you do find anything can you let me know how you get on.


Regards,

James

allan.fitzwater... Wed, 10/08/2008 - 04:47
User Badges:

Hi, you may have solved this already but there are two known problems with the ENG install.


Pls see below.

AvSubSetupUtilsENG023 is not in UK English

Symptom:

The following prompt is in American English, where it should be in UK English: [AvSubSetupUtilsENG023]

Text=...digits long. Use a password that is easy to remember, but hard for others to guess. For extra security, you can occasionally be asked to change your password.


Condition:

This occurs in Unity 4.2(1), and may be seen by users that are using UK English as their phone language.


Workaround:

If you have a Unity 4.0(5) disk set, you can copy the identical prompt from the Unity 4.0(5) disk set to the installed Unity 4.2(1) system.




CSCse95939 Bug Details Bug #2 of 7 | < Previous | Next >

Unity 4.2 ENG failsafe on accessing mailbox with *.

Symptom:

Dialing from external PSTN/Mobile phone, users are unable to enter their

mailbox after pressing *.

They will hear the "system is unavailable" failsafe message.


Steps to reproduce:

Call from outside (or any extension not associated with a subscriber) to subscriber that has CallForward into Unity.

On hearing the subscriber's greeting, press * to access mailbox.

Then enter username and password followed by hash.

Failsafe is generated.


Condition:

ML Unity with ENG loaded, and Default Phone Language set to ENG (UK English).

This problem occurs in Unity 4.2(1). The problem is fixed in Unity 5.0(1) and later.


Workaround:

This issue can be resolved in Unity 4.2(1) by applying a new SubSignIn_ENG.ps script file that is available from Cisco TAC.


Alternatively you can edit the relevant file and add a 2 on the end of continuemsg, as that is all that is wrong with the orig file.


Hope this helps!


richb1971 Thu, 10/09/2008 - 03:30
User Badges:

Allan,


Your a star! That is exactly what I'm hitting:


Symptom:

The following prompt is in American English, where it should be in UK English: [AvSubSetupUtilsENG023]

Text=...digits long. Use a password that is easy to remember, but hard for others to guess. For extra security, you can occasionally be asked to change your password.


Condition:

This occurs in Unity 4.2(1), and may be seen by users that are using UK English as their phone language.


Workaround:

If you have a Unity 4.0(5) disk set, you can copy the identical prompt from the Unity 4.0(5) disk set to the installed Unity 4.2(1) system.



Don't suppose you could tell me (and TAC) which file I need?


Rich

JAMES WEST Thu, 10/09/2008 - 03:46
User Badges:

Hi Rich,


We had a TAC case open for this and they dialed in via Meeting place and replaced the sign in file.


The file was called - Sign-INApplogs.evt


Hope this helps.


Regards,

James

allan.fitzwater... Mon, 10/20/2008 - 03:31
User Badges:

Rich, you could just copy avsubsetuputilseng023.wav from the 4.0X cd's or, from the current installation, find the avsubsetuputilseng030.wav and copy that to avsubsetuputilseng023.wav

The text is ever so slightly different. See below taken from the prompt.ini file in the commserver directory.


[AvSubSetupUtilsENG023]

Text=...digits long. Use a password that is easy to remember, but hard for others to guess. For extra security, you may be prompted to change your password periodically.


[AvSubSetupUtilsENG030]

Text=...digits long. Use a password that is easy to remember, but hard for others to guess. For extra security the system may ask you to change your password.


Be cautious! take a copy of the orig files and / or make sure your DiRT backup has run before you make any changes.


Actions

This Discussion