3750 show config display problem

Answered Question
Jun 10th, 2008
User Badges:

I have several 3750-48P running version c3750-ipservicesk9-mz.122-44.SE2 IOS and on some of the switches, when you telnet to them, and do a show config, the screen scrolls through the whole config without pausing. On other switches that are exactly the same, as far as I can tell, they pause after a page of information.

Correct Answer by Collin Clark about 8 years 10 months ago

To set the number of lines on the current terminal screen for the current session, use the terminal length EXEC command.


<font size="2">terminal length <i>screen-length </i></font>


24 is the default



Hope that helps

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Collin Clark Tue, 06/10/2008 - 09:21
User Badges:
  • Purple, 4500 points or more

To set the number of lines on the current terminal screen for the current session, use the terminal length EXEC command.


<font size="2">terminal length <i>screen-length </i></font>


24 is the default



Hope that helps

rdotson Tue, 06/10/2008 - 10:07
User Badges:

Excellent, do this stay in after a reboot?

Collin Clark Tue, 06/10/2008 - 10:44
User Badges:
  • Purple, 4500 points or more

Save it and it will (write memory)!

rdotson Tue, 06/10/2008 - 11:37
User Badges:

Actually that command only works in the current session.


terminal length

To set the number of lines on the current terminal screen for the current session, use the terminal length EXEC command.


terminal length screen-length


Syntax Description

screen-length

Your desired number of lines on the screen. The router uses this value to determine when to pause during multiple-screen output. A value of zero prevents the router from pausing between screens of output. When the output exceeds the screen length, it scrolls past.




Defaults

24 lines


Collin Clark Tue, 06/10/2008 - 11:41
User Badges:
  • Purple, 4500 points or more

So if you disconnect and come back in it's back to zero?


Works for me across multiple sessions as long as I save before exiting.


rdotson Tue, 06/10/2008 - 11:42
User Badges:

The correct way to fix it is under the VTY settings.


line vty 0 4

length 24 (default)


mine was set to 0.

Collin Clark Tue, 06/10/2008 - 11:45
User Badges:
  • Purple, 4500 points or more

Ahhh, must override the global setting. Thanks for keeping us updated.

Actions

This Discussion