Simple (I thought) Multicast test.

Unanswered Question
Jun 10th, 2008

I have an application that will require multicast to work. I wanted to set up a test so that a thin client at a remote site could send multicast traffic to our Home Office. The Home Office router is a 3825 and the remote is a 2851. Both are running 12.4 code. On both routers I enabled ip multicast routing and then entered the following commands on each:

3825 at Home Office

interface gig0/0

ip pim sparse-dense-mode

interface MultiLink1

ip pim sparse-dense-mode

2851 - remote site

interface gig0/0

ip pim sparse-dense-mode

interface serial0/0/0:0

ip pim sparse-dense-mode

After I did this I could see the multicast counter incrementing on the gig0/0 side on the 3825 but nowhere else.

I appreciate any help that any of you might be able to pass my way.

Thanks so much,

RI

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scottlivingston Tue, 06/10/2008 - 09:30

I will assume that your subscribing client to that mcast group lives on gig0/0 at the home office? So, the client isn't getting the feed?

scott

ROBERT ISAACS Tue, 06/10/2008 - 09:52

Scott,

The thin client that is initiating the multicast is on the gig0/0 on the 2851.

RI

n.nandrekar Tue, 06/10/2008 - 09:39

Hi!

So I guess you are seeing the multicast traffic coming in (through multilink) but not going out to the client???

Can you see see if client has sent igmp membership report and whether it is correctly recorded by the 3825? use " sh ip igmp group" for the same.

In case you dont see the group registered by the host, there might be a problem on the igmp side. Also make sure that you have enabled PIM on the interface connected to the host (multicast client/ lan). This is required on cisco devices to enable/register igmp on the interface. As wierd as it sounds, you require that even if it is the leaf node connected to lan.

Hope this helps. Please rate the post if it does.

Regards,

Niranjan

ROBERT ISAACS Tue, 06/10/2008 - 09:54

Niranjan,

I did a sh ip igmp group on both the 3825 and the 2851 (where the thin client is located). The multicast IP was on the gig0/0 interface on both results but was not on either serial interface.

RI

cisco_lad2004 Tue, 06/10/2008 - 10:56

is PIM enabled on each interfaces in the path between source and receivers ?

Sam

ROBERT ISAACS Tue, 06/10/2008 - 11:22

The actual thin client workstations are connected directly to Cisco switches but the router path is

2851 gig0/0

2851 serial0/0/0:0

3825 MultiLink1

3825 gig0/0

On the 3825 side, the server is directly connected to a 4507 Cisco switch.

Thanks,

RI

ROBERT ISAACS Tue, 06/10/2008 - 11:24

And as you see in the original posts the router interfaces all have ip pim sparse-dense-mode statements in them.

RI

n.nandrekar Tue, 06/10/2008 - 19:54

Hi!

Can you start the traffic and provide the outputs of the following commands,

sh ip mroute

sh ip igmp groups

sh ip pim nei

Regards,

Niranjan

cisco_lad2004 Tue, 06/10/2008 - 22:31

U need to set one of teh routers as RP, I recommend you do that on the closest one to source.

you can pick a loopback and that router and use it as RP ID, then paste that same line on all remaining routers.

another alternative is to use pim dense mode only, but this is becoming less and less popular these days.

HTH

Sam

ROBERT ISAACS Wed, 06/11/2008 - 07:24

Sam,

I entered the command ip pim rp-address 172.20.1.2 (MultiLink side of 3825). It still is not working. I do a show ip mroute and it does show that all of the multicast routes know the rp now.

RI

Harold Ritter Wed, 06/11/2008 - 07:43

Robert,

What is the TTL used by the application generating the multicast stream. Most application use a TTL value of 1 by default. Just something else to check.

Regards,

ROBERT ISAACS Wed, 06/11/2008 - 11:40

Sorry Sam, the ttl is 32. The actual server on the 3825 side is on a 4507 that has routing configured on it and the the thin client that is sending out the multicast packet is attached to either a 3560 switch that operates at layer 2 only. Does something have to be configured on the switches for this to work. Sorry for the ignorance but this is my first foray into multicasting.

Thanks people for the help!

RI

Actions

This Discussion