2 VLANs, 2 ADSL Routers, Now Routing?

Unanswered Question
Jun 11th, 2008

I initially set up a network on native vlan and ADSL Router 1.

The users are connected to a Cisco Router 1841 which has all the routes configured and a default route of 'ADSL Router1 IP Address'

Now I have set up a second VLAN and have an ADSL Router 2.

Intervlan routing still configured on the Cisco 1841.

a) How to configure such that VLAN2 users only access ADSL2 for internet access? and Native VLAN on ADSL1

b) What about the default route? Should it be removed?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Pravin Phadte Wed, 06/11/2008 - 05:09

Its been a bit difficlt for me to visulze it.

1841 router-1 connected to ---> ?---- Users

Is there a device in between ?

What ip address are the useres getting public/ private ?

ADSL Router2 connted to ---> ? -- Users ?

are the both routers interconnected and if yes how ?

The simple methothd which this can work would by configuring a dhcp pool for vlan 2 users on ADSL2.

Still if there can be a possible network diagram would help and basic config information.



hasnain321 Wed, 06/11/2008 - 05:24

You can do this by having two route map on the 1841 router where Vlan and routing is configured. One route map should matach the Vlan 1 and set next hop to ADSL Router 1 and second should match traffic from Vlan2 and next hop pointing to ADSL Router 2. In this way you can achieve this.

If you want to have redundency then you can also configure that with this option.

hasnain321 Fri, 06/13/2008 - 03:59

Can you copy and paste the current configuration on your router.

What I suggested earlier is still possible with your design.

Are you able to ping ADSL router 2 from your router after removing the default route.

Pravin Phadte Fri, 06/13/2008 - 04:41


As per the deisign there is a soluting not with route but with switching.

You may need to change the subnet for the same:

--On the switch.

Native Vlan 1.

ip address 192.168.1.x

Create Vlan 10 in place of 1 and 20 in place of 2

Configure the Switch port Connected to the routers as:

switchport trunk encapsulation dot1q

switchport mode trunk

--On router 1841

The interface connected to the switch

interface FastEthernet -/-

no ip address

duplex auto

speed auto

confgure 2 subinterface

interface FastEthernet-/-.10

encapsulation dot1Q 10

ip address 192.168.1.x


interface FastEthernet-/-.20

encapsulation dot1Q 20

ip address 192.168.2.x

Create 2 dhcp pool for vlan10 with network id 1.x and vlan 20 with network id 2.x

You will have to assaign the rest swith ports to vlan 10 and 20.

Native vlan would be diffrent and the two vlans will get diffrent ip address and will be routed through diffrent adsl.

Hope this helps.



rsabapathee Mon, 06/23/2008 - 23:01

Hi Parvin,

I was going through the setup and was wondering how would the default routes to the adsl routers be configured for each of the VLAN?


I try to access www.cisco.com from a PC in VLAN 10. PC IP:; GW: (1841 Router); DNS: (ADSL Router)

How will 1841 know that it should forward this traffic to ADSL Router in VLAN 10.

Similarly if the above was in VLAN 20.


rsabapathee Tue, 06/24/2008 - 22:56


some help with PBR for these 2 VLANs and default route will be much appreciated

rsabapathee Wed, 06/25/2008 - 21:56

Thanks indeed the example is close to what i am looking for.

However I have now complicated the diagram a bit. I have added a third path to the equation which is common to both VLANS. (Some applications are hosted there).

Will the following config ensure all the vlan traffic are sent to its ADSL router and ensure that applications on network 192.168.10.x are accessible to both through router

Access-list 1 permit ip

Access-list 2 permit ip

Access-list 100 deny ip any

interface fastethernet 0/1

ip policy route-map ADSL


route-map ADSL permit 10

match ip address 100

match ip address 1

set ip next-hop


route-map ADSL permit 20

match ip address 100

match ip address 2

set ip next-hop

ip route

rsabapathee Thu, 06/26/2008 - 08:17

Do you mean

1) I dont need the deny access list?

2) Wont the route map ignore the static route you specified?


This Discussion