Caller ID

Unanswered Question
Jun 11th, 2008
User Badges:

Hi All,

This may seem like a stupid question. We have CallManager 4.2 setup. When I call from my desk Cisco Phone to my office cell phone, the correct Caller ID info shows up. But, when I call from my desk phone or again to one of our employees cell phone, my info on the employees phone comes up as "private". I may have an idea as to why this is. But, I was wondering that I get some opinion from some more qualified professionals here. Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Rob Huffman Wed, 06/11/2008 - 06:13
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Naveen,


There is no such thing as a stupid question, they are all valid here :) Does this behaviour happen on every call to your co-workers mobile? What type of trunking are you using POTS/FXO or PRI (E1/T1)? Is your co-workers Cell from the same provider? Do other calls to his phone show the proper CLID?


Let us know,

Rob

Naveen Raj Janardhan Wed, 06/11/2008 - 06:35
User Badges:

There are about 10 people in my department 3 of them showed up as either "Unknown" or "Private", remaining of them showed correct caller id.

We are using PRI as our trunking. All our cell phones are provided by the same provider. Mostly, all desk phone calls on the employees cell phone shows up as "private".

Rob Huffman Wed, 06/11/2008 - 09:21
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Naveen,


Any problems with CLID when calling Land Lines?


Rob

Naveen Raj Janardhan Wed, 06/11/2008 - 11:11
User Badges:

No problem with caller id when calling to a land line. The caller id can be seen at the other end.

Jaime Valencia Wed, 06/11/2008 - 11:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

are all the calls being handled by the same PRI? or do you have one for landlines and one for mobiles?


a debug isdn q931 would show you the setup message and within it you can see the calling and called parties, if you're sending the right digits then it might be that someone in the middle is changing the info and a call to the telco might be a good idea


HTH


javalenc


if this helps, please rate

Naveen Raj Janardhan Wed, 06/11/2008 - 12:22
User Badges:

The calls are actually being handled by the sam PRI. But, can't it be the provider who could have turned off the Caller ID feature on the cell phone?

I will check what shows up on the command. thanks.

Naveen Raj Janardhan Thu, 06/12/2008 - 09:37
User Badges:

Jamie, can you please suggest on how to use the debug isdn q931 command? when I put in the command on the gateway it came up as " debug isdn q931 ON" not sure how to proceed from here. thanks.

Jaime Valencia Thu, 06/12/2008 - 09:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

#term mon

#debug isdn q931


test call


#u all

#no term mon


HTH


javalenc


if this helps, please rate

Actions

This Discussion