Cannot upgrade Aironet AP1231G

Answered Question
Jun 11th, 2008
User Badges:

I am trying to upgrade the IOS of my Aironet AP1231G. It is currently running IOS version 12.2(3)JA ED. I have tried numerous upgrades of assorted versions under the Aironet 1200 and 1230 categories but they do not work. I receive the error "ERROR. The software upgrade was interrupted and was not able to be completed". I have tried via tftp, http and via command line. Anyone know what the issue is? Any help would be great. Thanks.

Correct Answer by ericgarnel about 9 years 1 week ago

Give it an ip address in the same subnet that the AP is in and place the connection in the same vlan as the AP

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ericgarnel Wed, 06/11/2008 - 09:38
User Badges:
  • Gold, 750 points or more

what is the network setup between the AP and the computer hosting the upgrade image?

ubergeek1 Wed, 06/11/2008 - 09:48
User Badges:

They are two completely different subnets, that is about it. When I use tftp from the command line it is timing out stating that it failed to open archive.

ericgarnel Wed, 06/11/2008 - 09:52
User Badges:
  • Gold, 750 points or more

it sounds like either the tftp server is not listening, there is an acl blocking tftp traffic, or the path and/or file name for the image is incorrect.



ubergeek1 Wed, 06/11/2008 - 10:00
User Badges:

I can't even upgrade via http! What version should I upgrade to? I am at 12.2(13) JA ED. Should I connect to it via a console cable and use tftp that way?

ericgarnel Wed, 06/11/2008 - 10:06
User Badges:
  • Gold, 750 points or more

Ok, it sounds like there is a network issue between the AP and the box that the upgrade image is on. At this point, it does not matter which method you use, as you need to figure out where the network infrastructure problem is.


Does the ap have a default gateway for the mgmt subnet it is on?


is there a firewall or acls between the ap and the box with the image on it?

can you ping the tftp server from the AP?

ubergeek1 Wed, 06/11/2008 - 10:21
User Badges:

Thanks for your help. There is only a switch in between the two and I can ping from the AP. No firewalls are between the two devices. The AP is in its own vlan though.

ericgarnel Wed, 06/11/2008 - 10:27
User Badges:
  • Gold, 750 points or more

Ok, if I understand you correctly, you can ping the tftp server from the AP or from your workstation? Is there routing between vlans? if not, the tftp server needs to be in the same vlan.

ubergeek1 Wed, 06/11/2008 - 10:32
User Badges:

Yes that is correct. How do I add the tftp server to the vlan?

Correct Answer
ericgarnel Wed, 06/11/2008 - 10:38
User Badges:
  • Gold, 750 points or more

Give it an ip address in the same subnet that the AP is in and place the connection in the same vlan as the AP

Actions

This Discussion

 

 

Trending Topics - Security & Network