Reject call at H.323 GW

Unanswered Question
Jun 11th, 2008

I am trying to reject a call at our H.323 GW. I thought I had this correct but the call is still coming through.

voice translation-rule 1

rule 1 reject /8041234567/

!

voice translation-rule 2099

rule 1 /^2990/ /2099/

rule 2 /^2033/ /2040/

!

voice translation-profile LD_Trans_1

translate calling 1

translate called 2099

!

voice-port 0/2/0:23

translation-profile incoming LD_Trans_1

I am trying to reject Translation-Rule 1. I did a Debug Translation Detail and it does not show the call being rejected.

What am I doing wrong?

Thanks in advance

Trae

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rajesh Revuru Wed, 06/11/2008 - 09:11

What does it show when you test the translation rule by using

test voice translation-rule

Rajesh Revuru Wed, 06/11/2008 - 09:20

Can you post your dial-peer for incoming calls? I guess you have to apply translation-rule in there as well.

PS: If you are in production i would suggest you try after-hours.

cairns-a Wed, 06/11/2008 - 09:26

Thanks for your help. Here is the dial peer. Translation rule 2099 does work as is, so I would think just adding a new translation rule to the translation profile should work.

dial-peer voice 2099 voip

preference 1

destination-pattern 2099

progress_ind setup enable 3

voice-class codec 1

voice-class h323 1

session target ipv4:X.X.X.X

dtmf-relay h245-alphanumeric

no vad

Paolo Bevilacqua Wed, 06/11/2008 - 15:38

Hi, can you check with "debug isdn q931" that the calling number is indeed what you're trying to reject ?

Actions

This Discussion