New MOH Stream not playing

Unanswered Question
Jun 11th, 2008

CCM 4.2(3)

I recieved a new .mp3 file for our MOH. I dropped it in the 'drop here' folder, the conversion completed fine, I added the source to the MOH server okay, but when I change my phone to the new stream (both device and line), nothing plays when placed on hold.

The .mp3 file was no bigger than the old. The different codec files are present. When I change my phone back to the original stream the MOH works.

I tried backing everything out, deleting the source, the files and retrying the conversion but no go.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
asayani Wed, 06/11/2008 - 14:05

Try to restart IP voice media streaming app service. Also make sure that if you have an MOH server, then those files show up on that box.

benharned Thu, 06/12/2008 - 06:03

Restarted still no audio. The MOH is on the same box as CCM; no seperate MOH.

benharned Thu, 06/12/2008 - 06:06

I started looking at the XML files that are created along with the different audio files. I noticed that all the other past MOH files that have worked, the "LowDateTime" is negative. On the new MOH file it is a positive number AND greater than the "HighDateTime"

What would cause this and how to correct?

Michael Owuor Thu, 06/12/2008 - 07:03

Hi Ben,

I'd wait on editing the XML files just yet. Just for grins, try resetting the phone after making the change, and then test again. If it still doesn't work, capture the detailed CCM SDI traces collected while recreating the problem and post the log files here. They might reveal why you are having the issue.

If you get a chance to collect the CCM traces, please also note and describe the sequence of events performed to recreate the problem, including extensions involved, and time of the recreate. This would help ease the trace analysis.

Regards,

Michael.

benharned Thu, 06/12/2008 - 07:49

I was never planning on editing the XML file.

Actually I got it working. I again backed everything out and deleted all the files and references. I copied a new copy of the original in the 'drophere' folder and waited for it to process. Once it was done I looked at the file info and the "LowDateTime" was now negative. Tried it on my phone and bingo.

Not sure what happened but it seems the missing negative was the issue.

Actions

This Discussion