WCS on old WLSE appliance

Unanswered Question
Jun 12th, 2008

Has anyone out there managed to get WCS versions later than 4.2.61 running on an ex-WLSE appliance that's been converted ?

Would like to run with 4.2.81.0 but it needs a newer version of RedHat ? Customer doesn't want to have to pay for update.

Appreciate RH5 will be needed for future releases.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.4 (7 ratings)
Loading.
tkhan Thu, 06/12/2008 - 06:40

I'm running WCS 4.2.97.0 on a converted WLSE appliance with no issues. I would advise you to go to 4.2.97.0 as I had some bugs running 4.2.81.0.

mattgraham Fri, 06/13/2008 - 03:45

Thanks for the info. Did you need to do anything with the RedHat on it ? Or are you using the one out of the conversion pack ?

Thanks again.

tkhan Fri, 06/13/2008 - 04:45

I have performed multiple upgrades since converting WLSE to WCS. In each case I merely backed up my data, uninstalled the current version, installed the new version and restored my data. If the install file patched Redhat in some way, it was all done in the background.

dennischolmes Mon, 06/16/2008 - 07:12

Do make sure that you use the versions of Linux supported by Cisco TAC. Nothing bites worse than them not offering support because you used a slightly different version of OS than they want you to. I had that problem with a large corporate account in Detroit a year or so ago. The list of supported OS and version numbers is in the release notes and you can get those from the Cisco web site.

pmccubbin Mon, 06/16/2008 - 07:21

Dennis,

Excellent point. I rate it a "5" as it is always nice to be reminded to pay attention to the fundamentals. We all probably have a story or two like this. You are quite right that there is nothing worse than being denied support because you used an unsupported OS.

Best,

Paul

Juan Carlos Ari... Tue, 06/17/2008 - 07:54

This is interesting Tyron, could you help me a little more telling me how did you upgrade your WLSE to WCS?? Your Access Point instead of running with IOS are now running with LWAPP??

Regards,

tkhan Tue, 06/17/2008 - 09:27

Sure. I actually had two WLSEs running, supporting about 1,200 IOS AP1200s. I converted one WLSE to WCS and then proceeded to convert IOS APs to LWAPP by using the conversion tool. I then purchased a 1,500 AP license for the converted box. I have upgraded the box about 5 times since an early 4.x version. I am approaching the AP limit for my first WLSE==>WCS box and will probably convert the second one now that all IOS APs are off my network. Either that or go for the high end appliance that will support up to 2500 APs.

rob.huffman Tue, 06/17/2008 - 11:13

Hi Juan Carlos,

Here is a little added reference material;

Conversion of a WLSE Autonomous Deployment to a WCS Controller Deployment

http://www.cisco.com/en/US/products/ps6305/products_configuration_guide_chapter09186a00806b71db.html

Guidelines and Tools for Migrating to the Cisco Unified Wireless Network

http://www.cisco.com/en/US/prod/collateral/wireless/ps5679/ps5861/prod_white_paper0900aecd804f1a23_ns337_Networking_Solutions_White_Paper.html

For the WLSE to WCS conversion the important factor is what the current WLSE Model is. Have a look;

Customers can use the CiscoWorks WLSE to Cisco WCS conversion CDs (Cisco WCS SKU Family WCS-WLSE-UPG-K9) to convert an existing CiscoWorks WLSE (Model 1130-19 and 1133) to operate as a Cisco WCS server. This SKU family is price adjusted to make transitioning from CiscoWorks WLSE to Cisco WCS cost-effective.

WCS-WLSE-UPG-K9

http://www.cisco.com/en/US/prod/collateral/wireless/ps5755/ps6301/ps6305/product_data_sheet0900aecd804b4646_ps3915_Products_Data_Sheet.html

Hope this helps!

Rob

Juan Carlos Ari... Tue, 06/17/2008 - 11:52

Excellent link documentation, unfortunately I can not go further cause Cisco WLSE 1030 Express platform is not support it.

Thanks anyway.

Regards,

Juan Carlos

linchen2k Fri, 06/27/2008 - 06:38

hello tkhan,

the release notes of 4.2.97.0 state that it only can run on red hat ep 5. did u upgrade the OS too? or did u just uninstall previous version and put 4.2.97.0?

the converted WLSE should have red hat ep 4. thats why i am asking....

tkhan Fri, 06/27/2008 - 08:19

Other than the conversion CDs, I have not performed any update to Redhat via any CDs, etc. I have done incremental upgrades up to my current version 4.2.97.0. In performing these commands:

'uname -a' reveals:

Linux 2.6.9-22.EL #1 Mon Sep 19 18:20:28 EDT 2005 i686 i686 i386 GNU/Linux

'cat /etc/redhat-release' reveals:

Red Hat Enterprise Linux ES release 4 (Nahant Update 2)

'cat /proc/version' reveals:

Linux version 2.6.9-22.EL ([email protected]) (gcc version 3.4.4 20050721 (Red Hat 3.4.4-2)) #1 Mon Sep 19 18:20:28 EDT 2005

'cat /etc/issue' reveals:

Red Hat Enterprise Linux ES release 4 (Nahant Update 2)

Kernel \r on an \m

So I'm not sure what this requirement for Redhat v5 is for 4.2.97.0. WCS has been running without issue for over 3 weeks.

Only thing I haven't done is reboot. I think it should be up to the installation program to check the Redhat release and indicate if the version can/cannot be installed due to the Redhat version currently running.

linchen2k Mon, 06/30/2008 - 22:39

hello tkhan,

i used the 2 convertion CDs as well (one which is labeled WCS 4.0.83.0 and the other one is labeled as upgrade red hat 3 to red hat 4).

after installing i uninstalled WCS 4.0.83 in order to install a more recent version. i choosed 4.2.81.0.

well, the installer said that it recognized red hat 3 at my system, which should not be the case since i upgraded it with the conversion CD.

the output of the commands gave:

/$ uname -a

Linux 2.4.21-32.ELsmp #1 SMP Fri Apr 15 21:17:59 EDT 2005 i686 i686 i386 GNU/Linux

/$ cat /etc/redhat-release

Red Hat Enterprise Linux ES release 3 (Taroon Update 5)

/$ cat /proc/version

Linux version 2.4.21-32.ELsmp ([email protected]) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-52)) #1 SMP Fri Apr 15 21:17:59 EDT 2005

/$ cat /etc/issue

Cisco Wireless Control System

which is obviously more older than yours. that is strange. does cisco provide red hat updates in the incremental WCS updates??

unfortunaltey ciscos documentation is rare on that.

linchen2k Fri, 06/27/2008 - 06:30

I did the following:

Take a WLSE 1133 and put in the first conversion CD which puts WCS 4.0.83 on that machine.

After that, i reboot and put in the second conversion CD with the redhat update.

Then i had WCS 4.0.83 running.

Since i want to have an easy way to migrate the autonomus APs to LWAPs i want to upgrade to version. 4.2.x.

So i downloaded version 4.2.81.

Version 4.0.83 didnt support automatic installation, so i removed it and then reinstalled 4.2.81.

Here comes the problem: The installer indicated that it detected Red Hat Enterprise 3. This actually can not be, since in the previous steps i upgraded to red hat 4 with the cisco conversion CD. anyway i continued the installation and 4.2.81 was working just fine.

Now we are planing to upgrade the WCS (converted WLSE 1133) to version 5.x.

the release notes states that the WCS 5.x requires Red Hat Enterprise 5. How do i do that red hat upgrade? Can i just use the same red hat ep 5 installation CD which i would use on a normal Server system? (of course order the CD directly from red hat)

Or is WCS 5.x also running on the converted WLSE without any operating system upgrades? and if operating system upgrades are required, which one do i use??

anyone in the same situation?

the release notes of cisco WCS 5.x just state that red hat 5 is required and that a converted wlse is supported.

thanks a lot in advance guys !!!

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode