Cisco 3750 IP ARP incomplete

Unanswered Question
Jun 12th, 2008

Hi There,

Below is the configuration of the switch which is having problem. Summary of the problem is when I add host on Vlan210 I am not able to ping that host and if I execute is sh ip arp is it show "incomplete" status. Please help me out to solve this problem. For your better understand here I have copied the configuration and IOS version also. The hosts which is having problem is Linux and server is DELL 2950 and DELL R900

ip subnet-zero

ip routing

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 153-255 priority 28672

interface GigabitEthernet1/0/1

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/3

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/6

switchport access vlan 254

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/7

switchport access vlan 254

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/10

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/11

switchport access vlan 254

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/12

switchport access vlan 254

switchport mode access

spanning-tree portfast

interface GigabitEthernet1/0/16

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/17

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/18

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/19

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/20

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/21

switchport access vlan 210

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/24

switchport access vlan 255

switchport mode access

spanning-tree portfast

interface Vlan152

ip address 192.168.174.114 255.255.255.252

!

interface Vlan210

description Management

ip address 10.3.210.1 255.255.255.0

no ip redirects

no ip unreachables

!

interface Vlan254

ip address 10.3.254.1 255.255.255.0

!

interface Vlan255

ip address 10.3.255.66 255.255.255.224

!

router rip

version 2

redistribute static

network 10.0.0.0

no auto-summary

!

ip default-gateway 10.3.210.2

ip classless

ip route 0.0.0.0 0.0.0.0 10.3.210.2

sh ip arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.3.210.155 153 0015.c5eb.d835 ARPA Vlan210

Internet 10.3.254.182 93 001e.c9ce.3e80 ARPA Vlan254

Internet 10.3.210.182 0 Incomplete ARPA

Internet 10.3.255.69 0 0060.fb50.81fd ARPA Vlan255

Internet 10.3.255.66 - 0016.46cd.1244 ARPA Vlan255

Internet 10.3.255.65 0 001d.e622.5140 ARPA Vlan255

Internet 10.3.210.8 7 0017.5ab5.3daa ARPA Vlan210

Internet 10.3.210.3 156 00a0.8ea7.3b50 ARPA Vlan210

Internet 10.3.210.2 0 0000.5e00.0101 ARPA Vlan210

Internet 10.3.210.1 - 0016.46cd.1242 ARPA Vlan210

Internet 10.3.210.7 7 0060.161e.0182 ARPA Vlan210

Internet 10.3.210.6 0 0060.161e.0348 ARPA Vlan210

Internet 10.3.210.4 0 00a0.8ea7.3d70 ARPA Vlan210

Internet 192.168.174.114 - 0016.46cd.1241 ARPA Vlan152

Internet 192.168.174.113 156 0009.b68c.fd30 ARPA Vlan152

Internet 10.3.254.1 - 0016.46cd.1243 ARPA Vlan254

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 06/12/2008 - 03:26

sivakumar

The information that you provide here is a good start but is not enough for us to find the problem. You talk about a host and 2 servers. Are they all having this problem or just the host?

Can you tell us which port of the switch connects to what device that is having the problem?

And can you verify (probably using ipconfig) what is the IP address, subnet mask, and default gateway configured on the device that is having the problem?

If we know these things we may be able to help you solve this issue.

HTH

Rick

glen.grant Thu, 06/12/2008 - 03:36

Make sure you have the correct default gateway on the server nics, for 210 it should be 10.3.210.1 . Also check to make sure the L2 vlan is created and active with the show vlan command.

sivakumar.ks Thu, 06/12/2008 - 03:48

Thanks for your reply. L2 Vlan is active and few IP's communicating without any issue. I am trying assign vlan 210 to two DELL server which has linux OS and it is not working. All the Vlan shown in the config are active and pingable.

Jon Marshall Thu, 06/12/2008 - 03:53

So you have 2 separate DELL servers each running linux ?

As Glen says could you check the IP address/subnet mask/default-gateway on your linux servers ie.

ifconfig -a

will show NIC details

netstat -nr

will show the routing tables.

Also depending on your linux version it may well be running a firewall. If it is it could well be iptables so

iptables -L -n

this will show you if any firewall rules are preventing the ping.

Best to run all the above commands as root.

Jon

sivakumar.ks Thu, 06/12/2008 - 04:06

Yes I have checked everything. One of the host is Checkpoint R65 smartcentre server also. At the same time DELL Remote access card(DRAC)don't have any issue and the VLAN 254 is DRAC. The gateway 10.3.210.2 is checkpoint Firewall. I have update IOS recently two weeks ago and Smartcentre was working well with the IP address 10.3.210.5. But after rebooting it didn't communicate. I thought problem with like you , but second server which I rack mounted and booted first time today also had the same issue. It was working well in the test environment.

Siva

cheers,

siva

Richard Burts Thu, 06/12/2008 - 07:02

siva

Based on the description of the symptoms I believe that there are several possible causes of the problem which we should consideder:

- there may be a physical problem with the connection. If you tell us what switch interface the server is connected to and show interface from the switch we will know whether the interface to the server is up or not.

- there might be a configuration error on the server about its IP address, its subnetmask, or its default gateway. A configuration error here might prevent it from responding to the ARP request and produce the incomplete ARP which you experience. If you tell us exactly how the server is configured we will know whether this is the problem.

- the server might be on a port not assigned to the correct VLAN. The server might have the correct address but if its port is in a different VLAN than expected then it will not respond to the ARP request and this will produce the incomplete ARP.

Can you tell us these things so that we will know whether one of these is the problem?

HTH

Rick

Actions

This Discussion