Juniper SSG 20 optical interface connection to Cisco 4506

Unanswered Question
Jun 12th, 2008
User Badges:

Let me post the same issue to the Optical forum too:


Hello,


Here's the problem.


There's one Juniper SSG 20 firewall with JX-SFP-1GE-SX multimode fiber interface (850nm) (which I can control) and I have to connect it to Cisco 4506 switch which has WS-X4306-GB module and WS-G5484 GBIC interface (also multimode fiber).


SSG 20 shows link up. Cisco shows link down.


Unfortunatelly I don't have Cisco 4506 to play with, but I have to find solution for this system. Cisco 4506 show version is:


#show version

Cisco IOS Software, Catalyst 4000 L3 Switch Software (cat4000-I9K91S-M), Version 12.2(25)EWA9, RELEASE SOFTWARE (fc3) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 21-Mar-07 12:20 by tinhuang Image text-base: 0x10000000, data-base: 0x115C6158


ROM: 12.2(31r)SGA1

Dagobah Revision 226, Swamp Revision 34


XXXXXXX uptime is 3 weeks, 1 day, 3 hours, 20 minutes System returned to ROM by reload System restarted at 13:19:45 CEST Mon May 19 2008 System image file is "bootflash:cat4000-i9k91s-mz.122-25.EWA9.bin"


I was able to replicate issue with Cisco 3524 swtich (SSG20 shows link up, Cisco link down, physical down), and solution that I found was to enter interface level command: (config-if)#no negotiation auto. After this command, everything was showing state as "UP" and working as expected (there was traffic going through the optic)


When I suggested this command as a solution, administrator from the other side was claiming that this command returns "invalid input detected at ^ marker".


Can anyone tell me is there any known issue between those two products, and maybe alternative to this command, so I can turn off this IEEE 802.3z negotiation if that's the problem.


Thanks for assistance


Cheers


M.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
miloskv Fri, 06/13/2008 - 03:37
User Badges:

So I found my solution, but I want to know why is like this.


The solution was to enter on Cisco the following command:


(config-if)#speed nonegotiate


From this link: http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/sw_int.html


I can see on section: Configuring Link Negotiation on Gigabit Ethernet Ports that this command is doing negotiation exchange of flow-control parameters, remote fault information, and duplex information. Link negotiation is enabled by default.


And the funniest thing of all is, this speed nonegotiate command doesn't deal with the speed at all :)


Can someone confirm me what are remote fault information and flow control parameters

Tom Randstrom Fri, 06/13/2008 - 05:31
User Badges:
  • Gold, 750 points or more

You may want to also post this question on LAN or WAN Routing & Switching forums.

miloskv Fri, 06/13/2008 - 05:39
User Badges:

Thanks for the suggestion, I already did this :)


I'm sorry for posting on two forums at the same time, but it's a bad issue for me and I suppose it's important to be solved, not only for me, but to whole community out there who uses Juniper, Nortel or other devices with optical multimode fiber.


Thanks for understanding


M.

Actions

This Discussion