CLI LDAP Command

Unanswered Question
Jun 12th, 2008

I'm having an issue adding a new domain to bypass LDAP via the CLI, I'm using the following command:

listenerconfig edit IncomingMail rcptaccess new domain.co.za --action accept

there are extended options as per below but nothing to bypass LDAP

options - Various options to modify a host access policy:
--action Action to apply to address(es). Either
"Accept" or "Reject". Default is "Accept".
--cust_resp Specify a custom SMTP response. "No" or SMTP
acceptance response string.
--resp_code Custom SMTP response code. Default is 250 for
"Accept" actions, 550 for "Reject".
--bypass_rc Bypass receiving control. Default is "No".


Ultimately this would need to look like this in the RAT

domain.co.za ACCEPT bypass_ldap_accept=1

but the CLI does not have a command to bypass this in one string only via the prompt which does not allow me to add multiple domains at once

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kluu_ironport Thu, 06/12/2008 - 15:58

Great post Martinc!


After some trial and error, I was able to guess the correct combination. It's "-bypass_la" Yes

listenerconfig edit InboundMail rcptaccess new domain5.co.za --action accept --bypass_la Yes

bypass_la ---> where la stands for "ldap accept". I guessed this when re-visiting the process of adding an additional domain.

Would you like to bypass LDAP ACCEPT for this entry? [N]> Y





I'm having an issue adding a new domain to bypass LDAP via the CLI, I'm using the following command:

listenerconfig edit IncomingMail rcptaccess new domain.co.za --action accept

there are extended options as per below but nothing to bypass LDAP

options - Various options to modify a host access policy:
--action Action to apply to address(es). Either
"Accept" or "Reject". Default is "Accept".
--cust_resp Specify a custom SMTP response. "No" or SMTP
acceptance response string.
--resp_code Custom SMTP response code. Default is 250 for
"Accept" actions, 550 for "Reject".
--bypass_rc Bypass receiving control. Default is "No".


Ultimately this would need to look like this in the RAT

domain.co.za ACCEPT bypass_ldap_accept=1

but the CLI does not have a command to bypass this in one string only via the prompt which does not allow me to add multiple domains at once
kluu_ironport Thu, 06/12/2008 - 16:01

By the way, for those that don't know, these options can be seen if you type this on the CLI:

help listenerconfig


You can proceed most commands with help to see other options available for the command so that you don't have to go through the whole menu system interactively. It's great for automation.


I'm having an issue adding a new domain to bypass LDAP via the CLI, I'm using the following command:

listenerconfig edit IncomingMail rcptaccess new domain.co.za --action accept

there are extended options as per below but nothing to bypass LDAP

options - Various options to modify a host access policy:
--action Action to apply to address(es). Either
"Accept" or "Reject". Default is "Accept".
--cust_resp Specify a custom SMTP response. "No" or SMTP
acceptance response string.
--resp_code Custom SMTP response code. Default is 250 for
"Accept" actions, 550 for "Reject".
--bypass_rc Bypass receiving control. Default is "No".


Ultimately this would need to look like this in the RAT

domain.co.za ACCEPT bypass_ldap_accept=1

but the CLI does not have a command to bypass this in one string only via the prompt which does not allow me to add multiple domains at once

Actions

This Discussion