Etherchannel issue

Unanswered Question
Jun 13th, 2008

one of interfaces is suspended. total ports in the channel is 4. the other 3 are fine.

%EC-5-CANNOT_BUNDLE2: Gi0/24 is not compatible with Gi0/22 and will be suspended (speed of Gi0/24 is 100M, Gi0/22 is 1000M

under sh int status, the Gi0/24 is 100M. i havent hard code the speed and duplex on any ports so all port settings should be the same.

I hard code the speed to 1000M on gi0/24 but does not make any difference

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (3 ratings)
Loading.

Hi Francisco

Can I ask about the far end of the Ether Channel?

What is port Gi0/24 connected to and what is the configuration status of this far end port?

It sounds like you have your four ports configured to Auto Negotiate and for some reason Gi0/24 has auto negotiated a 100mbps link. This could be because the port at the far end is configured for 100mbps also.

Best Regards,

Michael

francisco_1 Fri, 06/13/2008 - 02:54

the other side is also 100M. Both ports setup with the switchport nonegotiate. same as the other working ports.

Kevin Dorrell Fri, 06/13/2008 - 02:57

Fransico,

My guess is that the cable has only two pairs working. That would work OK at 100 Mbps, but you need all four pairs (and at least CAT5E) for Gigabit. Try replacing the cable.

Kevin Dorrell

Luxembourg

n.nandrekar Fri, 06/13/2008 - 03:46

Hi!!!

I guess the issue here is different.. Are you trying to configure etherchannel with ports having different physical properties? As far as I know, you cannot bundle 1 fastethernet port along with another gig port. The ports must have the same physical properties for the etherchannel to form a bundle.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5014/prod_release_note09186a00800eaad4.html#22402

The above link gives that restriction.

Regards,

Niranjan.

francisco_1 Fri, 06/13/2008 - 03:50

Niranjan,

the capabilities on the ports are the same. the ports are gigs on the switches.

hasnain321 Fri, 06/13/2008 - 04:08

Have you replaced the cables ?

Try connecting the Gi0/24 to some other port that is working fine and see if that works.

Try changing the ports on both switches there is chance a port may not support 1000mb even if it is Gig

schughtai Fri, 06/13/2008 - 15:01

Couple of things you can try if you haven't already

1) swap the SFP GBIC connecter if u r using 1 or configure a different physical port and then add it to the etherchannel.

2) When you create the etherchannel ( I am assuming u r using port-channel group commands ) use the setting MODE ON.

hope this could help you

glen.grant Fri, 06/13/2008 - 16:38

Think Kevin hit on the head if its a gig port and its auto and only 100 . If even one single wire out of the 8 is bad is not good it will defualt to 100 meg.

Mishaal Khan Wed, 12/28/2011 - 01:01

I had the same issue and the internal patch pannel cabling was the culprit, probably missing a pair.

Directly connecting the 2 switches put them on 1 Gig whereas thru the patch pannel it was getting 100M.

Thanks for the tips guys

Kevin Dorrell Tue, 06/17/2008 - 01:37

Francisco,

Did it work, changing the cable? It would be useful to know, just so that we know which solutions work and which do not.

Kevin Dorrell

Luxembourg

Actions

This Discussion