UCCX CTI Port Not Registered

Unanswered Question
Jun 13th, 2008

Hi, i have the follow problem. The CTI port of the JTAPI Control Group are not registering. Pls. see the trace log of UCCX. Any idea?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
cristian.munoz Tue, 06/17/2008 - 14:09

The following services are out of service in the Service Engine:

Database Subsystem - Out of Sevice

eMail Subsystem - Out of Sevice

JTAPI Subsystem - Out of Sevice

MRCP ASR Subsystem - Out of Sevice

MRCP TTS Subsystem - Out of Sevice

cristian.munoz Tue, 06/17/2008 - 14:38

Hi, this is the message in the log of UCCX:

28: Jun 17 14:42:51.796 PDT %MIVR-SS_RTR-7-OFF:Disabling XDEBUGGING5 messages

629: Jun 17 14:42:51.968 PDT %MIVR-SS_RTR-5-ModuleStart:Module has successfully started: Module Name=Core RTR Subsystem

630: Jun 17 14:42:51.968 PDT %MIVR-GENERIC-5-ModuleStart:Module has successfully started: Module Name=Core RTR Subsystem

631: Jun 17 14:42:51.968 PDT %MIVR-SS_RTR-6-SS_IN_SERVICE:RTR subsystem IN_SERVICE:

632: Jun 17 14:42:51.968 PDT %MIVR-SS_TEL-6-SS_INITIALIZING:JTAPI subsystem initializing: Version Info=Cisco Jtapi version 2.2(3.4) Release

633: Jun 17 14:42:52.031 PDT %MIVR-CLUSTER_MGR-7-UNK:send: Cmd[ServiceStateChangedCmdImpl[6]={0:ServiceStateUpdate=[topLevel=CRS Engine,svc=CMT

Subsystem/Subsystem,state=INITIALIZING], 1:ServiceStateUpdate=[topLevel=CRS Engine,svc=CMT Subsystem/Subsystem,state=IN_SERVICE], 2:ServiceStateUpdate=

[topLevel=CRS Engine,svc=Core RTR Subsystem/Subsystem,state=INITIALIZING], 3:ServiceStateUpdate=[topLevel=CRS Engine,svc=Core RTR

Subsystem/Subsystem,state=IN_SERVICE], 4:ServiceStateUpdate=[topLevel=CRS Engine,svc=HTTP Subsystem/Subsystem,state=INITIALIZING], 5:ServiceStateUpdate=

[topLevel=CRS Engine,svc=JTAPI Subsystem/Subsystem,state=INITIALIZING]},nodeId=1,seq#=13]

634: Jun 17 14:42:52.031 PDT %MIVR-CLUSTER_MGR-7-UNK:try to process NodeIncrementalUpdateCmdImpl, nodeId=1, baseTick=397, nodeCurrTick=404, nodeState=6,

serVer=1, comp={}, serv={id=35:t=404:s=PARTIAL_SERVICE, id=88:t=399:s=IN_SERVICE, id=90:t=402:s=INITIALIZING, id=91:t=403:s=INITIALIZING,


635: Jun 17 14:42:52.156 PDT %MIVR-CLUSTER_MGR-7-UNK:send: ClusterContextPutEntryCmdImpl, nodeId=1, serviceUniqueId=15, sourceName=CRS Engine,

notifyAll=true, key=com.cisco.wf.subsystems.jtapi.RemoteSubsystemJTAPI CVDContextContainer: value=com.cisco.wf.subsystems.jtapi.SubsystemJTAPI$RemoteImpl

[RemoteStub [ref: [endpoint:[](local),objID:[10]]]], buffer length 1833

636: Jun 17 14:42:52.265 PDT %MIVR-SS_TEL-7-UNK:JTAPI Login Str:;login=ipcc_1;passwd=****;appinfo=Cisco IP IVR

637: Jun 17 14:42:52.328 PDT %MIVR-SS_TEL-6-CTIPORT_RECOV_THR_START:Starting CTI Port Recovery Thread: Recovery Thread Name=MIVR_SS_TEL_RECOVERY_0_-43-0

638: Jun 17 14:42:52.640 PDT %MIVR-SS_TEL-1-SS_OUT_OF_SERVICE:JTAPI subsystem in out of service: Failure reason=A number of route points are OOS - all

routes; A number of CTI ports are OOS - all ports

639: Jun 17 14:42:52.656 PDT %MIVR-SS_TEL-7-UNK:Number of CTI ports = 0

640: Jun 17 14:42:52.703 PDT %MIVR-LOG_MGR-6-CATALOG_LOADED:Log catalog loaded: Catalog=MIVR_SS_DB

641: Jun 17 14:42:52.703 PDT %MIVR-SS_DB-4-ON:Enabling WARNING messages

642: Jun 17 14:42:52.703 PDT %MIVR-SS_DB-5-ON:Enabling NOTICE messages

AHMED Ali Tue, 06/17/2008 - 16:48

Dear Cris,

It it real production installation or VMWare installation? because I faced same problem before with VMWare.


Ahmed Rizk

Chad Stachowicz Wed, 06/18/2008 - 22:53

What version is this? I can tell you that prior to 5.0, if a CTI port's config is changed directly in CUCM and not through the IPCC Express and a resync, they never register back properly. Delete the CTI port in CUCM and then do a IP Telephony resynd through IPCC Express and I bet it will fix your problem ;)


cristian.munoz Fri, 06/20/2008 - 11:53

Dear Chad

The CCM version is 4.2.3sr2b, the IPCC version is 4.0(5a). The JTAPI version in the IPCC is JTAPI 2.2(3.4). I checked the CRS sw and hw compatibility guide.

Yesterday i installed the IPCC again and the problem still continue.

Chad Stachowicz Fri, 06/20/2008 - 12:44

Your creating all the ports and Triggers through the UCCX and letting AXL push them into CCM right? in 4.05a, they won't register if you create them in CM and bypass having UCCX create them, silly I know..


cristian.munoz Fri, 06/20/2008 - 13:10

Dear Chad

Yes, I only configured by the UCCX web admin . I`m going to check what happens if i configure the cti port by the CCM web admin.

Chad Stachowicz Fri, 06/20/2008 - 13:19


delete all the CTI ports, then go to route plan report

and clear out all those dn's. Then resync from UCCX.


cristian.munoz Fri, 06/20/2008 - 13:35

Dear Chad, i delete all CTI port and of route plan report too, but still fail the register.

Chad Stachowicz Sun, 06/22/2008 - 11:48

Did you check what user the ports and CTI Route points are associated too? Maybe the UCCX is having a problem associating the ports and points automatically. Please ensure that all the CTI Ports are controlleds by the JTAPI user that UCCX creates.

jawilson_1 Mon, 06/30/2008 - 15:22


I have a VM lab and am having port issues as well. Ports have functioned since April/May. Then, in mid-May I get a regular busy..looked at MIVR logs and they show that the call is timing out because it will not connect to the port. BTW. ports all show registered. We've deleted ports, cleaned up the route plan, added them several times with no luck. What did you do to resolve your port registration issues?

AHMED Ali Tue, 07/01/2008 - 06:06

Dear All,

For me I faced this problem before, but It was CCM version problem, I was trying to integrated CCM 4.2.1 with IP-IVR/IPCCX 4.0.5a JTAPI subsystem was not working at all, but when I changed the CCM to version 4.2.3 It worked fine, I don't know if it's bug with this CCM version or not, I did also another change which should not affect Jtapi (Was using computer name instade of IP Add) & adding to lmhosts & host files.


Ahmed Rizk

c-pinilla Wed, 07/02/2008 - 00:37


It seems like some components are not active. You can see the next error in your traces.

E_CTI_SERVER_NOT_MASTER text: CSInboundMsgProcessor: The server is standby

Is it a HA deployment?




This Discussion