2620XM WIC`

Unanswered Question
Jun 13th, 2008

Just got a 2620XM which wic do i need to plug this guy to a cbale modem?? thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sirdudesly Fri, 06/13/2008 - 17:56

There is a cable DOCSIS WIC (might be a HWIC I can't remember) or you can just use your current cable modem and plug it into one of the fast ethernet ports, you may need to buy a module with an aditional fast ethernet port.

miguelv06 Fri, 06/13/2008 - 21:24

Can i use the Cisco NM-1FE-TX that is a fast ethernet 100mb to connect my modem?? so it will be like

Cable Modem > Cisco NM-1FE-TX and

From the interagted ethernet to 2950 switch???

sirdudesly Fri, 06/13/2008 - 22:54

yep that's what I mean :)

Personally i'd do it the other way around and have the cable modem going into the integrated ethernet and from your NM-1FE-TX to your 2950. It just seems more logical to me :P

miguelv06 Sat, 06/14/2008 - 04:14

But my question is will the NM-1FE-TX fit in the 2620xm and will it give me the 100Mb/s?????

hennigan Sun, 06/15/2008 - 06:35

Another option is not to buy a NM or WIC at all and configure it as a router-on-a-stick.

Configure the onboard FE with multiple dot1q VLANs, one for inside and one for outside traffic.

Configure a trunk on the 2950 to connect to the router, and one access port for the cable modem.

Router config:

interface f0/0

no shut

no ip address

interface f0/0.100

description outside from cable modem

encaps dot1q 100

ip address x.x.x.x 255.255.255.x

! assigned by cable company

ip nat outside

interface f0/0.200

description LAN to hosts

encaps dot1q 200

ip address

ip nat inside

! NAT and firewall rules as needed...

2950 switch:

int range f0/1-22

description inside hosts

switchport mode access

switchport access vlan 200

int f0/23

description Cable modem

switchport mode access

switchport access vlan 100

int f0/24

description trunk to router

switchport trunk encaps dot1q

switchport mode trunk

switchport trunk allow vlan 100,200

int vlan 200

descr switch access from inside

ip address

no shutdown

ip default-gateway

sirdudesly Sun, 06/15/2008 - 20:34

doing it that way does attract a slightly speed penatly though doesn't it?

hennigan Sun, 06/15/2008 - 22:08

In theory, as traffic is going both directions on the same physical interface.

In practice, with a 100 mbits/s FastEthernet trunk and a cable modem as the WAN link, you won't see any difference. Typical download from a cable modem is under 10 mbits/s and upload significantly less. This limits the routed traffic to something around 10% of wire speed. If you were pushing full duplex near wire speed, it would be a concern, but not with a cable modem feed.

LAN traffic is switched on the 2950 and doesn't touch the router, so no difference.

It consumes one port on the switch for the cable WAN feed, that's the only real penalty in this scenario.


This Discussion