QOS base on IP or VLAN

Unanswered Question
Jun 14th, 2008
User Badges:

Hi,

I'm currently researching QOS for a user who currently has 2M WAN link and would like to allocate 1M of the bandwidth sharing between 2x VLAN/IP and the remaining 1M sharing between the rest of the 20x other VLANs.

Im new with QOS and found that MQC may provide the solution.

Please confirm.


Thanks again.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (4 ratings)
Loading.
n.nandrekar Sat, 06/14/2008 - 09:34
User Badges:
  • Silver, 250 points or more

hi!!!

Thats right! You can use QMC to provide the required solution.

For the concepts of bandwidth reservations, refer :


http://www.cisco.com/en/US/docs/internetworking/technology/handbook/QoS.html#wp1020737


You will have to use the config like following:


class-map vlan2

match vlan 2


Policy-map test

class vlan 2

bandwidth 1000000


Apply the policymap on the interface in outpit direction.


Regards,

Niranjan

spremkumar Sat, 06/14/2008 - 09:42
User Badges:
  • Red, 2250 points or more

hi


you can refer the below config to start with.


access-list 100 permit ip x.x.x.0 0.0.0.255 any

access-list 100 permit ip y.y.y.0 0.0.0.255 any

access-list 101 permit ip z.z.z.0 0.0.0.255 any

!

class-map data1

match access-group 100

class-map data2

match access-group 101

!

policy-map qos-policy

class data1

bandwidth percent 50

class data2

bandwidth percent 50

!

interface Serial 0/0

service-policy output qos-policy

!


x.x.x0/y.y.y.0/z.z.z.0 - represents the subnet being used in your Vlan.


regds


Peter Valdes Sat, 06/14/2008 - 15:32
User Badges:

Hi,

Many thanks for both replies, I will set up the config soon this afternoon and test.

I've also read somewhere in this forum that this type of policy will only apply itself when the WAN is congested and then the QOS starts to apply the policy during this period. Is this correct?


Cheers.

n.nandrekar Sat, 06/14/2008 - 21:59
User Badges:
  • Silver, 250 points or more

Hi!

To be more specific, queuing will be applied to the traffic only when the interface is congested. If the interface has enough bandwidth to send the traffic, there is no point in queuing; is it? But any policying marking/classification will take place irrespective whether the interface is congested or not.

In your case, the parent policy will shape the Traffic to 2M. Now, if the total traffic for that interface is not exceeding 2M, there is no point in queueing. So if 1.5M of vlan2X traffic is coming and only .3M of other vlans, all traffic will be sent through, as there is no congestion and so no necessity to drop traffic.

So traffic from one class can use the bandwidth of other class if it is available. But if traffic from both classes is coming exceeding the bandwidth reservations of the class, then the mun. b/w comes into the picture. So the bandwidth specified in the class, is actually the min. bandwidth guaranteed for the class, which can be exceeded if unused bandwidth is available in other class.

So if you want to restrict your vlan2X traffic only to 1M, so that it never exceeds 1M even if bandwidth is available in outher class, you would have to police the traffic to 1M in addition to giving the bandwidth statement which will guarantee the bandwidth for the class.

Hope this makes things clear.


Regards,

Niranjan.

(Please rate helpful posts)

Peter Valdes Sun, 06/15/2008 - 01:33
User Badges:

Thanks everyone for the advise.

You guys are tops and all this makes sense now. I love this forum...


Thanks

Peter

Actions

This Discussion