Problem with "pppoe enable group global"

Unanswered Question
Jun 16th, 2008
User Badges:

Hello,


I configured a Cisco 1841 fpr PPPoE via Multilink PPP. I try to set the command


"pppoe enable group global"


for the FastEthernet0/0 and FastEthernet0/1 interfaces. But this command is not accepted, only "pppoe enable" is possible. Is there a big difference, could that cause a problem when I use "pppoe enable" instead of "pppoe enable group global"?


Here the example config for FastEthernet0/0:


interface FastEthernet0/0

description PPPOE WAN1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

no mop enabled

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Pravin Phadte Mon, 06/16/2008 - 04:42
User Badges:
  • Silver, 250 points or more

Hi,


If a PPPoE profile is not specified by using the group option, PPPoE sessions will be established using values from the global PPPoE profile.


PPPoE profiles must be configured using the bba-group pppoe command.

PPPoE on an Ethernet Interface Example


The following example enables PPPoE sessions on Ethernet interface 1/0. PPPoE sessions will be established using the PPPoE parameters in the global PPPoE profile.


interface ethernet1/0

pppoe enable

!

bba-group pppoe global

virtual-template 1

sessions max limit 8000

sessions per-vc limit 8

sessions per-mac limit 2



Hope this helps.


Regards,


Pravin

paolo bevilacqua Mon, 06/16/2008 - 06:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, despite what some older guide say, you don;t need any command beside pppoe-enable and pppoe-client for PPPoE under ethernet interface.


Note the ip commands under FA0/0 are unnecessary because the interface is not IP enabled, you should put them under dialer interface instead.


Hope thus helps, please rate post if it does!

Actions

This Discussion