BGP between 2811 & 3560

Answered Question
Jun 16th, 2008
User Badges:

As a lab, I am trying to run BGP between a 2811 (running advipsvcs 12.4(15)T1) and a 3560 in L3 switching mode (running ipsvcs 12.2(25)SEE3). The two devices become BGP peers, but never seem to exchange any routes! The configuration is simple -- two different AS with several network statements each (the router has loopback addresses, the switch 2 ports configuring as no swi and with IP addresses). Here are the configs:

Router:

router bgp 6002

no synchronization

bgp log-neighbor-changes

network 108.4.0.0

network 108.6.0.0

network 108.7.0.0

neighbor 108.4.0.1 remote-as 6502

no auto-summary

Switch:

router bgp 6502

no synchronization

bgp log-neighbor-changes

network 100.1.1.0

network 101.1.1.0

network 102.1.1.0

network 105.1.1.0

network 108.4.0.0

neighbor 108.4.0.2 remote-as 6002

no auto-summary


I can't see how it could be simpler than that, but neither device sees any bgp routes. show ip bgp shows the session established and keep-alives being processed...but no route refreshes at all.


Any ideas?


Thanks!

Correct Answer by Edison Ortiz about 8 years 10 months ago

The show ip bgp should be populated in the router with the routes received from the neighbor and its local routes.


The local routes are important as they are needed for advertisement.


You need to make sure you are matching the networks in the routing table so they can be added into BGP.


Per your routing table output and your BGP configuration, they are not matching.


For instance, in the router - you have /24 subnets for the interfaces but the BGP network statement does not contain the subnet information (mask).


For example:


Router routing table:


108.0.0.0/16 is subnetted, 1 subnets

C 108.4.0.0 is directly connected, FastEthernet0/0



Your BGP network statement should be:


network 108.4.0.0 mask 255.255.0.0


HTH,


__


Edison.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Mon, 06/16/2008 - 06:02
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Please post the routing table from both devices along with the bgp table.


show ip route

show ip bgp


Thanks


__


Edison.

riedmueller Mon, 06/16/2008 - 06:06
User Badges:

Certainly -- sho ip bgp is empty, so I added sho ip bgp summary...


Router#sho ip rou

Codes:

Gateway of last resort is not set


102.0.0.0/24 is subnetted, 1 subnets

C 102.1.1.0 is directly connected, Loopback2

100.0.0.0/24 is subnetted, 1 subnets

C 100.1.1.0 is directly connected, Loopback0

101.0.0.0/24 is subnetted, 1 subnets

C 101.1.1.0 is directly connected, Loopback1

108.0.0.0/16 is subnetted, 1 subnets

C 108.4.0.0 is directly connected, FastEthernet0/0

105.0.0.0/24 is subnetted, 1 subnets

C 105.1.1.0 is directly connected, Loopback4

Router#sho ip bgp


Router#

Router#sho ip bgp summ

BGP router identifier 105.1.1.1, local AS number 65001

BGP table version is 1, main routing table version 1


Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

108.4.0.2 4 65002 22 22 1 0 0 00:10:40 0

Router#


pod2-layer3-switch#sho ip rou

Codes:

Gateway of last resort is not set


108.0.0.0/16 is subnetted, 3 subnets

C 108.4.0.0 is directly connected, FastEthernet0/1

C 108.6.0.0 is directly connected, FastEthernet0/2

C 108.7.0.0 is directly connected, FastEthernet0/3

pod2-layer3-switch#sho ip bgp


pod2-layer3-switch#

pod2-layer3-switch#sho ip bgp summ

BGP router identifier 108.7.0.1, local AS number 65002

BGP table version is 1, main routing table version 1


Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

108.4.0.1 4 65001 20 20 1 0 0 00:10:22 0

pod2-layer3-switch#




Correct Answer
Edison Ortiz Mon, 06/16/2008 - 06:14
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The show ip bgp should be populated in the router with the routes received from the neighbor and its local routes.


The local routes are important as they are needed for advertisement.


You need to make sure you are matching the networks in the routing table so they can be added into BGP.


Per your routing table output and your BGP configuration, they are not matching.


For instance, in the router - you have /24 subnets for the interfaces but the BGP network statement does not contain the subnet information (mask).


For example:


Router routing table:


108.0.0.0/16 is subnetted, 1 subnets

C 108.4.0.0 is directly connected, FastEthernet0/0



Your BGP network statement should be:


network 108.4.0.0 mask 255.255.0.0


HTH,


__


Edison.


riedmueller Mon, 06/16/2008 - 06:29
User Badges:

Edison,


That worked. I thought the mask information was optional in BGP...I guess not. I will obviously have to read some more.


Thanks


Jim

u2637ps Fri, 06/20/2008 - 21:28
User Badges:

BGP works differently when you have no auto-summary in the config. If you leave this out then bgp starts to be classful and any routes in a class that match will allow the class to be advertised not just the specific.


If you put no auto-summary in the config then bgp expects to see the exact route in the routing table before it will announce them.

sdoremus33 Sat, 06/21/2008 - 16:01
User Badges:
  • Bronze, 100 points or more

If you are using the no auto-summary option make sure you have a route in place that point s to dest Ex

Sh ip route

x.x.x.x y.y.y.y z.z.z.z

x.x.x.x= src

y.y.y.y sn

z.z.z.z dest

Make sure that the route matches the route in the BGP table and if not you will not see the routes under BGP

Basically there are two tables

1. RIB Routing table

2. BGP Table

for a route to be adv via BGP under these circumstances must have an existing route in the routing table and must match the route in the routing table

Ex.

In RIB

ip route x.x.x.x 255.255.255.0 y.y.y.y

if this is in place BGP should adv your route

To verify

type in the following

show ip bgp x.x.x.x

show ip route | i bgp

Actions

This Discussion