How do i get rid of this on my switch

Unanswered Question
Jun 16th, 2008

Hi Guys,

I keep of getting this message even upon logging in on my switch. Is there any problem/error on my switch? if any, how do i diagnose this kind of message?

Appreciate your help,

Username: jreblora

Password: 2008 Jun 16 21:10:34 EDT -04:00 %PAGP-5-PORTFROMSTP:Port 2/1 left brid

ge port 2/1

IDF_2-1_2980B> (enable) 2008 Jun 16 21:10:54 EDT -04:00 %PAGP-5-PORTTOSTP:Port 2

/1 joined bridge port 2/1

2008 Jun 16 21:11:42 EDT -04:00 %PAGP-5-PORTFROMSTP:Port 2/1 left bridge port 2/

1

2008 Jun 16 21:11:59 EDT -04:00 %PAGP-5-PORTTOSTP:Port 2/1 joined bridge port 2/

1

2008 Jun 16 21:16:28 EDT -04:00 %SYS-4-P2_WARN: 1/Invalid traffic from multicast

source address 0b:17:fb:64:0b:a1 on port 3/33

Thanks,

Jong

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
michael.leblanc Mon, 06/16/2008 - 19:30

I can't advise you on the specific messages being logged, but I do feel you would benefit from configuring "logging synchronous" on the console and VTY lines.

It will help ensure unsolicited messages and debug command output are not interspersed with solicited device output and prompts.

Notice how messages are interspersed with your login prompts which makes it difficult to interact with the CLI.

Although the document liked below may not be for the same platform you are working with, its discussion of the "logging synchronous" command would still be beneficial:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_40_se/configuration/guide/swlog.pdf

Do a quick search for the "logging synchronous" term in the document to find the relevant description of its function.

foxbatreco Mon, 06/16/2008 - 19:43

This means remote switch sends BPDU's on that port and the local switch receives the same on one of its ports.

It appears u have PAGP etherchannel configured ON for all ports.If its set to ON, ports on both sides of etherchannel should be ON.In such cases,switches will never try negotiating bundle by itself with PAGP negotiation packets ,as its forcefully doin so.The messages normally indicate the ether bundle getting formed on one end but not on other.When etherbundle forms BPDU's are sent on a single link.Start by checking the status with sh port 2/1 n see wats the status of the port.

If its in err-disable state it means the etherchannel misconfig creates these spanning tree loop.

there is an errdisable recovery cause all command which is useful to enable errdisable recovery for any event tat causes this state.set errdisable-timeout enable all is the cmd on cat os.

den issue a show errdisable-timeout which shows the ports currently in this state and reason.

depending on the reason rectify it.if its ether misconfig then check each port of bundle on either sides are identical in terms of speed/duplex,identical PAGP modes,port vlan memberships et al.

finally u can enable the ports

babatunde_sanda Thu, 10/02/2008 - 04:22

Fox is right. This is likely as a result of ether channel configuration mismatch on the port(s). You are receiving PAGP messages in the logs. You can either make the other connecting end PAGP or remove the configuration all together on this switch. I normally prefer turning them on instead of using the protocols (PAGP, LACP).

int range fa 1/1 - 1/2

Channel group 1 mode on

Do this on the switch ports connecting both devices. As Fox mentioned, the ports must have similar characteristic ie either all trunks, same duplex, speed, etc

The logging synchronous will not remove the messages. It will only allow your commands not to be interrupted when typing.

hope this helps.

Giuseppe Larosa Fri, 10/03/2008 - 11:02

Hello Jong,

you are using a CatOS switch.

Up to some catos version (<8.1) for example in catos 7.6 everytime a port makes an up/down you get the left bridge and joined bridge message.

So the first series of messages:

Password: 2008 Jun 16 21:10:34 EDT -04:00 %PAGP-5-PORTFROMSTP:Port 2/1 left brid

ge port 2/1

IDF_2-1_2980B> (enable) 2008 Jun 16 21:10:54 EDT -04:00 %PAGP-5-PORTTOSTP:Port 2

/1 joined bridge port 2/1

2008 Jun 16 21:11:42 EDT -04:00 %PAGP-5-PORTFROMSTP:Port 2/1 left bridge port 2/

1

2008 Jun 16 21:11:59 EDT -04:00 %PAGP-5-PORTTOSTP:Port 2/1 joined bridge port

simply means the port 2/1 has had an up/down.

To be noted that this happens for all ports including user access ports for example.

the port doesn't need to be part of a channel-group to send out these messages.

I used a cat6509 for some years and we saw the messages until we upgraded catos from 7.6 to 8.1 (if I remember correctly or was 8.2)

So I think that a catos upgrade could avoid these messages that can be handy in a lab environment but meaningless in a production environment where every morning users switch on their PCs

the second message is something different a frame with an illegal multicast MAC source address has been received on port 3/33

I see this kind of messages almost every day in different campus networks, I tried to follow up and I never found a real device because the illegal address is not placed in the CAM table.

I see it sometimes on uplinks but when I go to the core switch I cannot find it.

I don't know how to get rid of this but it shouldn't be a real issue.

Hope to help

Giuseppe

glen.grant Sat, 10/04/2008 - 15:32

That just means whatever is hooked to that port has gone up to down and down to up again , its not a problem . If it really bothers you just set your logging level for PAGP to 4 and you won't see it again as the message is a level 5 message , if you set the logging level lower than 5 it will not show up again . Also it may go away if you turn etherchannel port negotiation off on ports that do not need it such as user ports.

Actions

This Discussion