3750ME Total output drops, OutDiscards

Unanswered Question
Jun 16th, 2008

Hi,

I am testing a 3750ME switch as L2 device with iperf and Agilent router tester. I have a physical loop on 2 fastethernet ports - one port is access in vlan A and the other is access in vlan B. On the switch uplink both vlans are allowed. The test traffic comes from the uplink via vlan A, loops to vlan B via the physical loop and then goes back via vlan B through the uplink.

I have tested a lot of Cisco switches in this way and had no issues until now. Now I have 18 OutDiscards (Total output drops) on one of the fastethernet interfaces, connected via the physical loop.

The IOS is 12.2(44)SE1. I've read the release notes for this IOS, aka

http://www.cisco.com/en/US/docs/switches/metro/catalyst3750m/software/release/12.2_44_se/release/notes/OL14631.html

where it says:

CSCsj53001

The Total- output-drops field in the show interfaces privileged EXEC command output now displays accurate ASIC drops.

so the counters are correct.

I generate less then 5Mbps duplex traffic, so the switch must not be overloaded.

Do you have any idea why I get these 18 output errors?

Regards,

Mladen

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mchin345 Fri, 06/20/2008 - 12:01

Might be due to buffer failures and incorrect buffer configurations. In order to resolve this issue, perform buffer tuning on the device.

Pavel Bykov Fri, 06/27/2008 - 03:07

Please generate more definitive test - clear the counters and generate much more traffic - like 100 Mbps (full port speed if you're not using the uplinks on 3750ME).

Also, be sure the port is in "switchport" mode, because there could be an issue with mac addresses when switch is routing.

Is your test setup in pure L2? without L3?

Actions

This Discussion