LAP1131 can't join WLC4400

Answered Question
Jun 16th, 2008
User Badges:

Hi everybody


I'm trying to deploy a WLC 4400 with several LAP1131 but I have problems: the APs can't join the controller.


Before starting this conversation, I have read the documentation, set DHCP option 60 and 43 with appropiate values, checked that I can ping the WLC from the AP, set the LWAPP manually... but there's no way. The error message is:


LWAPP_CLIENT_EVENT: spamResolveStaticGateway - gateway found

Sent Msg Type : DISCOVERY_REQUEST

Msg Length : 21

Msg SeqNum : 0

LWAPP_CLIENT_EVENT: spamHandleDiscoveryTimer: Could not discover any MWAR


Reading the forums, it seems that 'Could not discover MWAR' means that the AP can't reach the controller but, what else can I do?


WLC4400 version: 4-1-185

LAP1131 version: c1130-rcvk9w8-mx 12.3(11)JX1


Any help?


Dani

Correct Answer by Rob Huffman about 9 years 1 month ago

Hi Dani,


Just a note to explain this behaviour;


Q. My 1131 lightweight access point (LAP) does not register with my 4402 Wireless LAN Controller (WLC). What can be the possible reason for this?


A. One common reason is that the Lightweight Access Point Protocol (LWAPP) Transport Mode is configured on the WLC. A 4402 WLC can operate in both Layer 2 and Layer 3 LWAPP mode. Whereas, an 1131 LAP can only operate in Layer 3 mode. Layer 2 mode is not supported on the 1131 LAP. So, if the WLC is configured with the LWAPP Transport Mode of Layer 2, then your LAP does not join the WLC. In order to overcome this problem, change the LWAPP Transport Mode of the WLC from Layer 2 to Layer 3.


In order to change the LWAPP Transport Mode using the GUI, go to the WLC page and locate the second selection in the main field which is LWAPP Transport Mode. Change this to Layer 3 and reboot the controller. Now, your LAP is able to register with the controller.



From this good Q&A doc;


http://www.cisco.com/en/US/products/ps6366/products_qanda_item09186a008064a991.shtml


Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
pirateoftheairwaves Tue, 06/17/2008 - 00:12
User Badges:

Based on experience:


1. make sure the switchport where the ap is plugged in is in access mode.

2. From the port where you plugged the ap, be sure you can reach the controller and the dhcp server. you can test this by plugging ur notebook.

3. if #2 is verified, connect to the ap and try to issue the following command:

lwapp ap controller ip address


HTH!

telecodi Tue, 06/17/2008 - 03:14
User Badges:

Hi Pirate


I have re-checked that:


1. All switchports are in access mode

2. I can reach the WLC from any port and any device connected to the swicth. My labtop is assigned with an DHCP IP address and I can ping and access the WLC. From the LAP1131 console, I can ping the WLC also

3. I have added manually (I had already don it) the IP WLC's IP address with the command lwapp ap controller ip address


No way, tha AP doesn't join the WLC. I have also discovered that the AP has CDP disabled. Anybody know how to enable it?


Dani

pirateoftheairwaves Tue, 06/17/2008 - 06:27
User Badges:

another incident when this happened to me was when the controller and the ap are having mismatch regulatory domain. you can check on the country setting of the wlc and the ap model.


also try to look carefully at the debug lwapp events enable command output from the wlc. it might reveal some clues as to why the ap isn't joining the wlc. you can just plugged in only a single ap so you can see messages from one ap only.


HTH!

dennischolmes Tue, 06/17/2008 - 08:42
User Badges:
  • Gold, 750 points or more

Make sure the date and time on the controller is accurate. The APs have x509 certificates that allow the controller to open the LWAPP tunnel. If the time is off by more than 2 hours you could run into this problem. If this doesn't function do an LWAPP debug for all LWAPP events, authentication events, and dhcp events.

telecodi Wed, 06/18/2008 - 02:41
User Badges:

Hi pirate, dennis


the problem was choosing Layer2 infrastructure. I don't know why but the APs didn't register with WLC until I changed to LAYER3 infrastructure.


Anyway, thank you very much for your help!


Dani

dennischolmes Wed, 06/18/2008 - 03:02
User Badges:
  • Gold, 750 points or more

Sorry, I didn't notice you were using layer 2. Layer 2 uses SNMP to manage the APs. SNMP can not be used across multiple vlans easily from the controller point of view. It is also no longer fully supported by Cisco. Layer 3 is your friend and what allows all of the really cool stuff in lwapp to happen. Fast secure roaming, voice, and video streaming just to name a few. The 2100 series controllers don't even have layer 2 as an option.

pirateoftheairwaves Wed, 06/18/2008 - 06:47
User Badges:

use L3 mode if WLC resides in a diff subnet than where ur LAP's are. and use L2 if they are on the same subnet. or probably there are some compatibility issues bet ur WLC and LAPs...

Correct Answer
Rob Huffman Wed, 06/18/2008 - 04:22
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Dani,


Just a note to explain this behaviour;


Q. My 1131 lightweight access point (LAP) does not register with my 4402 Wireless LAN Controller (WLC). What can be the possible reason for this?


A. One common reason is that the Lightweight Access Point Protocol (LWAPP) Transport Mode is configured on the WLC. A 4402 WLC can operate in both Layer 2 and Layer 3 LWAPP mode. Whereas, an 1131 LAP can only operate in Layer 3 mode. Layer 2 mode is not supported on the 1131 LAP. So, if the WLC is configured with the LWAPP Transport Mode of Layer 2, then your LAP does not join the WLC. In order to overcome this problem, change the LWAPP Transport Mode of the WLC from Layer 2 to Layer 3.


In order to change the LWAPP Transport Mode using the GUI, go to the WLC page and locate the second selection in the main field which is LWAPP Transport Mode. Change this to Layer 3 and reboot the controller. Now, your LAP is able to register with the controller.



From this good Q&A doc;


http://www.cisco.com/en/US/products/ps6366/products_qanda_item09186a008064a991.shtml


Hope this helps!

Rob

Actions

This Discussion

 

 

Trending Topics - Security & Network