BRI Isdn Voice Ports locking up

Unanswered Question
Jun 17th, 2008

Hi,

I have an issue where the BRI ports are not always been released after making a call they get permanantley stuck in the state. Details below:

sh voice call summ

PORT CODEC VAD VTSP STATE VPM STATE

============== ======== === ==================== ======================

0/1/0.1 - - -

0/1/0.2 - - -

0/1/1.1 - - -

0/1/1.2 - - -

0/3/0.1 - - -

0/3/0.2 None - S_SETUP_FAIL S_TSP_WAIT_RELEASE

0/3/1.1 - - -

0/3/1.2 None - S_SETUP_FAIL S_TSP_WAIT_RELEASE

IOS version is 12.4(1)exp.

Config for the BRI is :

nterface BRI0/2/0

description QSIG Trunk in TE mode

no ip address

isdn switch-type basic-qsig

isdn overlap-receiving T302 3000

isdn tei-negotiation remove

isdn point-to-point-setup

isdn incoming-voice voice

isdn global-disconnect

isdn send-alerting

isdn sending-complete

isdn static-tei 0

isdn timeout-signaling

isdn skipsend-idverify

I think this is looking like a software bug but was wondering if anyone has ever seen this.

Any help appreciated.

Cheers

Kev

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 06/17/2008 - 02:50

I see that youre, using 12.4(1) something. Please upgrade to a minimum of 12.4(3j). If you will be using CME and need new features, upgrade to 12.4(11)XJ4.

Hope this helps, please rate post if it does!

kevinhobson2000 Tue, 06/17/2008 - 03:59

Hi,

Thanks for the advice i will upgrade the software and see if it resolves this.

Cheers

Kev

kevinhobson2000 Tue, 06/17/2008 - 23:02

I have attached some debug output for VTSP, CCAPI inout and isdn events. I am getting this error.

Jun 17 15:57:15.909 BST: ISDN **ERROR**: Module-CCBRI Function-_SetNewChan Error-Cannot get an idle channel from chan mgt. Data-

0, 2

but this could be just because there are no channels available due to the voice ports not being released.

Cheers

Kev

Paolo Bevilacqua Wed, 06/18/2008 - 00:32

Which experimental software? Upgrade to 12.4(3j) as suggested above and your issues should be should be solved.

lohmannt Mon, 11/10/2008 - 05:35

Kev -

I am getting the same error:

ISDN **ERROR**: Module-CCBRI Function-Unknown error function Error-Unknown or unexpected event received. Data- 7, 500

But I am on code: (C2800NM-SPSERVICESK9-M), Version 12.4(19)

__________________

Did upgrading solve your issue? and what code are you running?

Thanks - 3sa

gsidhu Fri, 04/16/2010 - 08:32

Hi

I'm getting the same issue:

**ERROR**: Module-CCBRI  Function-_SetNewChan

This is for a new install. I'm running 124-24.T3 on a Cisco 1861 over BRI using H323

Is this errot message down to a software issue or proble at the Telco end?

kevinhobson2000 Mon, 04/19/2010 - 02:37

Hi,

Its been a long time since i had this problem but if i remember rightly the IOS and the PBX software had to be upgraded to resolve the issue in my case.

Thanks


Kev

gsidhu Sun, 04/25/2010 - 08:47

Hi,

Before I installed this version I noticed that I was no longer getting the same error message that you responed to. The issue had been escalated to the Service Provider so I'm wondering if they made any changes.  Instead the gateway was sending disconnect with 'Network out of order' message.

This turned out to be a simple configuration error. (I had missed the h323 interface statements).

Thanks to all of you who tried to help.

Actions

This Discussion