Prefer OSPF over EIGRP

Answered Question
Jun 17th, 2008
User Badges:

I have a router configured for both routing protocols (OSPF/EIGRP)...EIGRP is configured on the Frame Relay interface and OSPF is configured on an MPLS interface. I am not doing ANY redistribution...I have added MPLS to this router but still want to keep Frame as backup.


Whenever I have both routing protocols up and running, EIGRP takes over due to AD. I have used the distance command under the OSPF process to specify a better AD than EIGRP but EIGRP still takes over.


I want to have both up and running and EIGRP used as backup in the event OSPF is down.


I would like to get some ideas of what my best options are.





Correct Answer by Harold Ritter about 9 years 1 month ago

Paul,


* Changing the ospf distribute-list to match the one currently used for eigrp will ensure that you get all the more specific routes in ospf as well.


* I would suggest using "ip summary-address" on the interface towards the frame-relay cloud on the aggregation router.


Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Harold Ritter Tue, 06/17/2008 - 05:47
User Badges:
  • Cisco Employee,

Paul,


Changing the AD will not have any affect if the routes learnt from eigrp are more specifics than the ones learnt from ospf.


Why do you have more specific routes in eigrp and not in ospf?


Regards,

paul.coley Tue, 06/17/2008 - 07:38
User Badges:

I tried changing this morning so that I have the same summary routes being received from FRAME and MPLS. I would like to just receive the summary routes on both interfaces, but EIGRP is still showing specific routes. I haven't done anything (distribute-list, ip summary-address, etc..) on the other end of the Frame Relay link.



router eigrp 100

passive-interface default

network 10.65.0.0 0.0.255.255

network 162.53.136.0 0.0.0.255

network 162.53.137.0 0.0.0.255

network 172.29.65.188 0.0.0.3

network 172.29.73.188 0.0.0.3

network 172.29.80.188 0.0.0.3

network 172.30.65.188 0.0.0.3

network 172.30.73.188 0.0.0.3

default-metric 64 60000 250 128 1500

distribute-list 40 in Serial0/0.11

distribute-list 40 in Serial0/0.22

distribute-list 40 in Serial0/0.33

distribute-list 40 in Dialer22

distance eigrp 200 200

no auto-summary


EIGRP - Distribute List on Serial Interface

==========================================

access-list 40 permit 0.0.0.0

access-list 40 permit 172.20.0.0 0.0.255.255

access-list 40 permit 172.21.0.0 0.0.255.255

access-list 40 permit 172.22.0.0 0.0.255.255

access-list 40 permit 172.23.0.0 0.0.255.255

access-list 40 permit 162.53.0.0 0.0.255.255

access-list 40 permit 10.0.0.0 0.0.0.255


OSPF - Distribute List on MPLS interface

===========================================

router ospf 1

router-id 162.53.136.166

log-adjacency-changes

passive-interface default

no passive-interface FastEthernet0/0.3

network 10.41.80.232 0.0.0.3 area 2355

network 10.65.0.0 0.0.255.255 area 2355

network 162.53.136.0 0.0.0.255 area 2355

network 162.53.137.0 0.0.0.255 area 2355

distribute-list OSPF-ROUTES-IN in

distance 80


ip access-list standard OSPF-ROUTES-IN

permit 0.0.0.0

permit 10.0.0.0

permit 162.53.0.0

permit 172.20.0.0

permit 172.21.0.0

permit 172.22.0.0

permit 172.23.0.0

Harold Ritter Tue, 06/17/2008 - 08:12
User Badges:
  • Cisco Employee,

Paul,


ACL 40 allows all the more specific subnets.


for instance, access-list 40 permit 172.20.0.0 0.0.255.255

accepts any routes, which two first character match 172.20.


Also bear in mind that the distribute-list will not perform any summarization.


You can do explicit summarization using the ip summary-address statement.


Regards,

paul.coley Tue, 06/17/2008 - 08:32
User Badges:

*So shall I changes my OSPF distribute list to match exactly what I am doing with ACL 40?


* Configure ip summary-address on the other end pointing towards this router(R1)?


Correct Answer
Harold Ritter Tue, 06/17/2008 - 09:13
User Badges:
  • Cisco Employee,

Paul,


* Changing the ospf distribute-list to match the one currently used for eigrp will ensure that you get all the more specific routes in ospf as well.


* I would suggest using "ip summary-address" on the interface towards the frame-relay cloud on the aggregation router.


Regards,

Actions

This Discussion