snmpv3 get and traps authpriv with LMS3.0

Unanswered Question
Jun 17th, 2008

Hi everyone,

I've installed LMS3.0 Decemberupdate and I configured snmpv3 authpriv at all devices and LMS and it works fine. But after that I configure trap via authpriv then snmp-get does not works any longer. ( snmp-server host trap version 3 priv V3User ), when I delete the entry and configure the snmpv3-user new, then LMS can get snmp info's again.

Thanks Rene

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Joe Clarke Tue, 06/17/2008 - 07:22

LMS (i.e. DFM) does not support SNMPv3 traps. However, the trap configuration should not interfere with the ability to query objects. Please post your entire SNMP configuration.

renekrueger Tue, 06/17/2008 - 22:46

Hello Joe,

thanks for your answer.

Here is my config:

Switch(config)# snmp-server group authgroup v3 auth read v3read write v3write

Switch(config)# snmp-server user authuser authgroup v3 auth md5 mypassword priv des56 cryptopassword

Switch(config)# snmp-server host 10.x.x.x traps version 3 priv authuser

Switch(config)# snmp-server enable traps

Switch(config)# snmp-server view v3read iso included

Switch(config)# snmp-server view v3write iso included

That's all. If I configure the priv-trap command, then the LMS can't get snmp infos from device.

Thanks René

Joe Clarke Wed, 06/18/2008 - 09:16

I can't reproduce on a switch running 12.2(44)SE2. However, there are some problems with your config. It should be:

snmp-server group authgroup v3 priv read v1default write v1default notify v1default

snmp-server user authuser authgroup v3 auth md5 mypassword priv des cryptopassword

snmp-server host 10.x.x.x traps version 3 priv authuser

snmp-server enable traps

renekrueger Wed, 06/18/2008 - 22:47

Hi Joe,

thanks. Sorry I have typing error in group config, but that it is not the problem. When I configure the "snmp-server host 10.x.x.x traps version 3 priv authuser" command then LMS3.0 can not get snmp information (Cisco View). Is it correct that LMS3.0 DecemberUpdate 2007 not supported snmpv3 traps? Is there a update for support snmpv3 traps in DFM?

Thanks René

Joe Clarke Thu, 06/19/2008 - 06:43

No, SNMPv3 trap support is not available in LMS. Without more details about the device and software version, I cannot offer anymore advice. The config I posted works fine for me in that I am able to manage the device with SNMPv3 authPriv.

wbenton-0 Mon, 06/23/2008 - 23:37

Have you tried configuring your device to use informs instead of traps?

snmp-server enable informs

instead of

snmp-server enable traps

Informs have all required information in them to be processed properly by an SNMPv3 Engine, but traps do not.

If you want to configure your system so that traps can be used, then you'll also need to use the following:

snmp-server engineID remote {SNMP Srv IP} {engineID}

Where {SNMP Srv IP} needs to be replaced by the NMS server you want to send the traps to.

And, where {engineID} is the engineID of your SNMP device.

Of course, you would not include the squiggly brackets.

So the command should look something like:

snmp-server engineID remote 80000001010000121212121212

If your NMS server was IP and your Device EngineID was 80000001010000121212121212.



This Discussion