Configuring ATM interface (RFC2684)

Unanswered Question
Jun 18th, 2008

I need to configure a HWIC-1ADSL card to work MPoA. The Telco has given me the next data:

Modo de Acesso: MPoA (RFC 2684)

Tipo de Encapsulamento: LLC SNAP

VPI: 0

VCI: 37

WAN IP: A.B.C.D/255.255.255.252

My config is:

bridge irb

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/3/0.1 point-to-point

no snmp trap link-status

bridge-group 2

pvc 0/37

encapsulation aal5snap

!

!

interface BVI2

ip address A.B.C.D 255.255.255.252

ip nat outside

ip virtual-reassembly

bridge 2 protocol ieee

bridge 2 route ip

It does not work. How can I see if the config is right?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
victorgarciaternero Wed, 06/18/2008 - 07:29

Hi, this is the output of "sh dsl interface" command:

ATM0/3/0

Alcatel 20190 chipset information

ATU-R (DS) ATU-C (US)

Modem Status: Showtime (DMTDSL_SHOWTIME)

DSL Mode: ITU G.992.5 (ADSL2+) Annex A

ITU STD NUM: 0x03 0x2

Chip Vendor ID: 'STMI' 'BDCM'

Chip Vendor Specific: 0x0000 0x618F

Chip Vendor Country: 0x0F 0xB5

Modem Vendor ID: 'CSCO' ' '

Modem Vendor Specific: 0x0000 0x0000

Modem Vendor Country: 0xB5 0x00

Serial Number Near: FOC11213DAQCISCO73993206

Serial Number Far:

Modem Version Near: 12.4(11)T4

Modem Version Far:

Capacity Used: 13% 100%

Noise Margin: 38.0 dB 8.0 dB

Output Power: 17.0 dBm 12.0 dBm

Attenuation: 24.0 dB 8.0 dB

Defect Status: None None

Last Fail Code: None

Watchdog Counter: 0x61

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction: 0x00

Interrupts: 185965437 (0 spurious)

PHY Access Err: 0

Activations: 1

LED Status: OFF

LED On Time: 0

LED Off Time: 0

Init FW: init_AMR-R-2.5.042_no_bist.bin

Operation FW: AMR-R-2.5.042.bin

FW Source: embedded

FW Version: 2.5.42

DS Channel1 DS Channel0 US Channel1 US Channel0

Speed (kbps): 0 2045 0 1020

Cells: 0 969 0 20546291

Reed-Solomon EC: 0 0 0 0

CRC Errors: 0 0 0 0

Header Errors: 0 0 0 0

Total BER: 0E-0 0E-0

Leakage Average BER: 0E-0 0E-0

Interleave Delay: 0 0 0 0

LOM Monitoring : Disabled

DMT Bits Per Bin

000: 0 0 0 0 0 0 0 7 9 A A B C C C C

010: C C C C D C C C B B B B A A A 9

020: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

030: 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2

040: 2 2 2 2 2 2 2 2 2 2 2 2 4 4 2 2

050: 2 2 2 2 3 4 4 2 2 4 2 2 4 2 4 4

060: 4 2 4 4 4 4 4 4 4 2 4 4 4 4 2 4

070: 4 4 2 4 2 4 2 2 2 4 2 4 2 2 2 4

080: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

090: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

0A0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

0B0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

0C0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

0D0: 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0

0E0: 0 0 0 0 0 2 2 2 0 2 2 0 2 2 2 2

0F0: 0 2 2 2 2 2 4 4 2 2 4 2 4 4 4 2

100: 2 4 4 4 4 4 4 4 4 4 4 4 2 2 2 2

110: 2 2 2 2 2 2 2 2 3 2 4 2 2 2 2 2

120: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

130: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

140: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

150: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

160: 2 2 0 2 0 0 0 0 0 0 0 0 0 0 0 0

170: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

180: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

190: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1A0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1B0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

Could be a problem with routing? Now I have the connection with the Telco through ethernet, so there is a default route ("ip route 0.0.0.0 0.0.0.0 dialer0"). If I type "ip route 0.0.0.0 0.0.0.0 bvi2" 50% of packets are lossed (it makes load-balancing between the two interfaces).

Thanks. Regards.

Paolo Bevilacqua Wed, 06/18/2008 - 07:48

Hi, remove dialer interface if you have any, and remove both default routes referencing interfaces, instead put one with the IP of the other valid address on your /30 wan subnet.

That should get you going. I haven't asked about default route because often the card doesn't connected at all and needs FW update. If you want to benefit from the updates too the url is:

ftp://ftp.cisco.com/pub/access/800

The one you want is 3-0-3 and there is a doc about.

Hope this helps, please rate post if it does!

victorgarciaternero Wed, 06/18/2008 - 08:46

Hi Paolo,

I have done all you say, and it doesn't work. Is there any debug command where I could see what is happening? Thanks

Best Regards.

Paolo Bevilacqua Wed, 06/18/2008 - 09:02

Post the last byte of you given IP so we can check the address for default route and ping.

Paolo Bevilacqua Wed, 06/18/2008 - 09:44

Ping default gw and check: "show ip route 0.0.0.0", "show atm pvc 0/37", "show bridge 2 verbose".

If the circuit was working with another router, you might need to clone mac of the working device in case it's cached somewhere.

Also check with telco that your circuit is fully activated, as sometime they forget to do so. In some networks, when you're activated for the first time, you can initially access a certain address via web only for registration, check if that is your case.

victorgarciaternero Wed, 06/18/2008 - 10:07

I think the route table is right. The output of "show atm pvc 0/37":

Description: N/A

ATM0/3/0.1: VCD: 6, VPI: 0, VCI: 37

UBR, PeakRate: 1020 (2406 cps)

AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0, Encapsize: 12

OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)

OAM up retry count: 3, OAM down retry count: 5

OAM END CC Activate retry count: 3, OAM END CC Deactivate retry count: 3

OAM END CC retry frequency: 30 second(s),

OAM SEGMENT CC Activate retry count: 3, OAM SEGMENT CC Deactivate retry count: 3

OAM SEGMENT CC retry frequency: 30 second(s),

OAM Loopback status: OAM Disabled

OAM VC Status: Not Managed

ILMI VC status: Not Managed

InARP frequency: 15 minutes(s)

InPkts: 52, OutPkts: 134, InBytes: 3744, OutBytes: 6325

InPRoc: 52, OutPRoc: 0, Broadcasts: 134

InFast: 0, OutFast: 0, InAS: 0, OutAS: 0

InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)

CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0

Out CLP=1 Pkts: 0

OAM cells received: 0

F5 InEndloop: 0, F5 InSegloop: 0,

F5 InEndcc: 0, F5 InSegcc: 0, F5 InAIS: 0, F5 InRDI: 0

F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0

OAM cells sent: 0

F5 OutEndloop: 0, F5 OutSegloop: 0,

F5 OutEndcc: 0, F5 OutSegcc: 0, F5 OutAIS: 0, F5 OutRDI: 0

F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0

OAM cell drops: 0

Status: UP

The output of "show bridge 2 verbose" is:

Total of 300 station blocks, 300 free

Codes: P - permanent, S - self

Flood ports (BG 2) RX count TX count

ATM0/3/0.1 0 0

Thank you very much Paolo,

Regards.

Paolo Bevilacqua Wed, 06/18/2008 - 10:48

That all seems fine. Can you ping the default gw ? If so, have you configure ip nat inside and globally with an ACL ?

victorgarciaternero Wed, 06/18/2008 - 23:03

Hi Paolo, I can't ping the default gateway. I have configured nat, but it was working well with the other connection. No ACL is configured. Any idea?

Best Regards.

Paolo Bevilacqua Thu, 06/19/2008 - 09:13

Ok, try:

no interface BVI2

interface ATM0/3/0.1 point-to-point

no bridge-group 2

ip address A.B.C.D 255.255.255.252

ip nat inside source list 1 interface ATM0/3/0.1 overload

Replace ACL 1 with whatver number you've configured for NAT.

Actions

This Discussion