Can't delete mobility group members

Unanswered Question
Jun 18th, 2008

I'm in the process of redeploying a 4400-series WLAN controller (v.4.2.130.0). I want to remove the mobility group members, however I get the following error whenever I attempt to do so:

"Cannot delete mobility group member. Any anchor should be deleted from WLAN first."

The thing is, there are no WLANs, hence no anchors. I tried recreating WLANs and adding the mobility members as anchors, deleting the anchors, then trying to delete the mobility group members, yet I still get the aformentioned error message. I attempted this via GUI and CLI. I also tried rebooting the controller and that didn't help either.

I'm out of ideas, so I'm hoping that someone has seen this before and knows a workaround. Let me know if you have any suggestions, other than clearing the config on the controller. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
charlesbisel Wed, 06/18/2008 - 07:25

Looks like I solved my own issue. Here is the workaround/fix:

1.) From the Mobility Groups page, click on the EditAll button.

2.) Change the IP address of the mobility group member that you want to delete. Click Apply.

3.) You will be returned back to the Mobility Groups page where you will now be able to delete the mobility group member without error.

Andrew.Prescott Wed, 06/18/2008 - 23:58

If you are trying to re-deploy the controler in another situstion then it may be better to restore the controler to factory defaults.

This can be done from the GUI, CLI or from login after power cycling the controler.

charlesbisel Thu, 06/19/2008 - 09:54

In an ideal world, yes, I would typically blast the config and start from scratch.

However, when you are employed by a global corporation and the controller you are working on happens to be located on another continent, restoring the controller to factory defaults is simply not an option.

Mark Withers Wed, 06/04/2014 - 12:04

I know it's old, but I found the answer because I had the same problem.

 

I had to cheat by using the CLI though. ;)

 

"show mobility anchor" in the CLI will list your mobility groups and anchors. That tells you the WLAN ID that has this IP address as an anchor, very helpful if you have dozens of WLANs. eg:

(WiSM-slot1-1) >show mobility anchor


Mobility Anchor Export List

 WLAN ID     IP Address            Status
 -------     ---------------       ------
 5           1.2.3.4          Control and Data Path Down
 5           1.2.3.5         Up

 GLAN ID     IP Address            Status
 -------     ---------------       ------

 

 

 

So now I go into my WiSM GUI and I go to WLANs, hover on the blue arrow next to WLAN ID 5, and click on "Mobility Anchors."

 

I hover on the blue arrow next to 1.2.3.4 and click "Remove." There's a dialog box about temporarily disrupting users on that WLAN, so you may have to do this during a maintenance window if it's in production. Need to do this for each WLAN.

Then you can go back to the Controller tab, Mobility Management, Mobility Groups, and remove 1.2.3.4 successfully.

ralphfowler Sun, 10/19/2014 - 08:18

Thank you!

Even though this is an old thread, it helped me here in 2014.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode