Pravin Phadte Wed, 06/18/2008 - 09:09
User Badges:
  • Silver, 250 points or more

Hi,


Suppose the bgp is running on a router somewhere else in as 1, and that the bgp routes are inhected into IP eigrp routing process 1. You must use filteres to ensure that the proper routes are advertised.


The example configuration for the router use of access filteres and a distribution list to fileter routes advertised to bgp neighbours.Also comfiguration commands for redistribution between bgp and Ip eigrp.


lets consider R1-R2-R3 connetd and R1 running BGP and R3 running EIGRP


Config R2

router bgp 1

network 131.108.0.0

neighbour 192.5.10.1 remote-as 2

neighbour 192.5.10.15 remote-as 1

neighbour 192.5.10.24 remote-as 3

redistribute eigrp 1

distribute-list 1 out eigrp 1


all networks that should be advertise from router are controlled with access list


access-list 1 permit 131.108.0.0

access-list 1 ermit 150.136.0.0

access-list 1 permit 128.125.0.0


router eigrp 1

network 131.108.0.0

network 192.5.10.0

redistribute bgp 1



Below is a link for more refrence.


http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009487e.shtml


Hope this helps,


regards,


Pravin

saimbt Wed, 06/18/2008 - 09:39
User Badges:

Hey Pravin, I guess while redistributing BGP into EIGRP, I need to define bandwidth, delay, reliability, load, and MTU.


-Sai.

Pravin Phadte Wed, 06/18/2008 - 09:57
User Badges:
  • Silver, 250 points or more

Hi,


Config R2

router bgp 1

network 131.108.0.0

neighbour 192.5.10.1 remote-as 2

neighbour 192.5.10.15 remote-as 1

neighbour 192.5.10.24 remote-as 3

redistribute eigrp 1 metric 10000 100 255 1 1500

distribute-list 1 out eigrp 1


all networks that should be advertise from router are controlled with access list


access-list 1 permit 131.108.0.0

access-list 1 ermit 150.136.0.0

access-list 1 permit 128.125.0.0


router eigrp 1

network 131.108.0.0

network 192.5.10.0

redistribute bgp 1


bandwidth: In units of kilobits per second; 10000 for Ethernet

delay:In units of tens of microseconds; for Ethernet it is100 x 10 microseconds = 1 ms

reliability:255 for 100 percent reliability

load:Effective load on the link expressed as a number from 0 to 255 (255 is 100 percent loading)

MTU:Minimum MTU of the path; usually equals that for the Ethernet interface, which is 1500 bytes


Also the link provided below will help.


Hope this helps.



Regards

Pravin

Actions

This Discussion