SIP Trunk - inbound calls

Answered Question
Jun 18th, 2008
User Badges:

Dear Experts,

i have a problem in my lab (AS4500XM with CCM5 -10.100.252.10- and SIP trunk). the problem is:

when i make call from the PSTN to our internal number i can not receive any call but i can make call to the outbound ,and below you can see the gateway cofiguration :



------------------------------------------


ip cef

!

!

isdn switch-type primary-net5

!

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

sip

bind control source-interface GigabitEthernet0/0

bind media source-interface GigabitEthernet0/0

!

!controller E1 7/0

pri-group timeslots 1-31

!

controller E1 7/1

pri-group timeslots 1-31

!

controller E1 7/2

pri-group timeslots 1-31

!

controller E1 7/3

!

controller E1 7/4

!

controller E1 7/5

!


interface GigabitEthernet0/0

ip address 10.100.252.120 255.255.255.0

duplex auto

speed auto

negotiation auto

!


!

interface Serial7/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

no cdp enable

!

interface Serial7/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

interface Serial7/2:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!


ip default-gateway 10.100.252.1

!

no ip http server

!

!

!

!

!

control-plane

!

!

!

voice-port 7/0:D

!

voice-port 7/1:D

!

voice-port 7/2:D

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 7/1:D

!

dial-peer voice 2 voip

destination-pattern 2T

session protocol sipv2

session target ipv4:10.100.252.10

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

!

!

!

-------------------------------------



Thanks all


Correct Answer by paolo bevilacqua about 9 years 1 month ago

Ok, add "incoming called-number ." and "direct-inward-dial" under DP 1. What you're hearing is router dialtone.


Likely you will also need "isdn overlap-receiving" under serial interface.


Then make sure that telco is sending the same number as extensions, else you will need translations.


As an appreciation to those providing naswers, please rate useful posts with the scrollbox below!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Wed, 06/18/2008 - 09:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, try configuring "incoming called-number ." under DP 2.


Then if still trouble collect "debug ccsip message" with "term mon".


Hope this helps, please rate post if it does!

islam.irshaid Wed, 06/18/2008 - 09:54
User Badges:

Thanks

i tried "incoming called-number " with no benefit's

and no messages from "debug ccsip message " also with terminal mon.



what can i do to solve it ?


paolo bevilacqua Wed, 06/18/2008 - 09:59
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, if you don't seen any sip message on the router, it means the CM does not send the call, and you should configure it to do so. Unfortunately I cannot help you with the CM configuration.

islam.irshaid Wed, 06/18/2008 - 10:03
User Badges:

okay, but in the fact i can send call from any phone (Cisco IP-Phone) from the company.


but the problem is when i try to make call from any PSTN number or mobile to our internal phones. and i can see the calls on the gateway when i use ISDN layer 3 debug .

paolo bevilacqua Wed, 06/18/2008 - 10:23
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ok, and which called number do you seen in ISDN? Currently you have configured only numbers beginning with 2 to be sent to CM.

islam.irshaid Wed, 06/18/2008 - 10:27
User Badges:

yes ,,, all internal numbers beginning with 2.

but no call go to internals

and i can hear some voice like modem

Correct Answer
paolo bevilacqua Wed, 06/18/2008 - 10:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ok, add "incoming called-number ." and "direct-inward-dial" under DP 1. What you're hearing is router dialtone.


Likely you will also need "isdn overlap-receiving" under serial interface.


Then make sure that telco is sending the same number as extensions, else you will need translations.


As an appreciation to those providing naswers, please rate useful posts with the scrollbox below!

paolo bevilacqua Wed, 06/18/2008 - 10:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You are welcome, thanks for the appreciation and good luck!

Actions

This Discussion