INBOUND CALL WITH SIP TRUNK

Unanswered Question
Jun 18th, 2008

Dear Experts,

i have a problem in my lab (AS4500XM with CCM5 -10.100.252.10- and SIP trunk). the problem is:

when i make call from the PSTN to our internal number i can not receive any call but i can make call to the outbound ,and below you can see the gateway cofiguration :

------------------------------------------

ip cef

!

!

isdn switch-type primary-net5

!

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

sip

bind control source-interface GigabitEthernet0/0

bind media source-interface GigabitEthernet0/0

!

!controller E1 7/0

pri-group timeslots 1-31

!

controller E1 7/1

pri-group timeslots 1-31

!

controller E1 7/2

pri-group timeslots 1-31

!

controller E1 7/3

!

controller E1 7/4

!

controller E1 7/5

!

interface GigabitEthernet0/0

ip address 10.100.252.120 255.255.255.0

duplex auto

speed auto

negotiation auto

!

!

interface Serial7/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

no cdp enable

!

interface Serial7/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

interface Serial7/2:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

ip default-gateway 10.100.252.1

!

no ip http server

!

!

!

!

!

control-plane

!

!

!

voice-port 7/0:D

!

voice-port 7/1:D

!

voice-port 7/2:D

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 7/1:D

!

dial-peer voice 2 voip

destination-pattern 2T

session protocol sipv2

session target ipv4:10.100.252.10

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

!

!

!

-------------------------------------

Thanks all

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbyron Wed, 06/18/2008 - 10:55

Try enabling "header-passing" under sip under voice service voip.

Janet

AHMED Ali Wed, 06/18/2008 - 11:30

hello Islam

Check if you are receiving the correct digits from PSTN side, as I see in VG configuration it must starts by 2XXXXX

Use this debug command “debug voip ccapi inout”

Regards,

Ahmed Rizk

islam.irshaid Wed, 06/18/2008 - 20:56

Thanks all

the problem was solved by using "incoming called-number ." and "direct-inward-dial" under DP 1

Actions

This Discussion