×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

2106 not giving more than 1 IP address from DHCP server

Unanswered Question
Jun 18th, 2008
User Badges:

I have a 2106 controller setup and all the APs associate to it fine. I can access the web interface fine. When we add machines to the wireless network we start getting "IP address conflict" in Windows XP. The network is one subnet with 3com switches on native VLAN1.


The controller:

Management: 130.0.0.60/16 Untagged Port 1

AP Manager: 130.0.0.61/16 Untagged Port 1

Virtual: 1.1.1.1


DHCP Server is 130.0.1.227


The code is 4.2.112 and using Windows 2003 server for DHCP. The APs are getting different addresses, but the clients are not.


I am thinking of running "config dhcp proxy disable" to see if that corrects the issue, but I dont know if that is the right route to take.


Anyone have any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Wed, 06/18/2008 - 15:03
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Recheck your configuration on your wlc and also your ip helper address on your layer 3 interface.

mrjsprague Fri, 06/20/2008 - 06:38
User Badges:

I looked over the configuration again and everything seems fine. I talked with the IT staff about a helper statement and they said they dont have one because their network is one big network. They only have the one vlan.


Would it be possible to run DHCP off the controller to try to narrow down the problem? We could add a range of addresses to exclude from the DHCP server and run them on the controller instead.

Scott Fella Sat, 06/21/2008 - 11:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

You can do that.... One thing you should know is that it is recommended that your wireless users are not placed on the same subnet as the wired. This has caused issues in the past and that is why its not recommended to have a mixed subnet.

mrjsprague Thu, 06/26/2008 - 13:19
User Badges:

I have tried the DHCP server running on the controller and we still get that error.


Since the 2106 only does layer 3 LWAPP, if we changed to a 4400 series controller that can do layer 2 LWAPP, would that work in this environment?


Thanks fella5 for the information you provided.

Scott Fella Thu, 06/26/2008 - 13:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Layer 2 is only supported in the old airspace ap's. Post your show run-config.... so we can see if there is a configuration issue.

Scott Fella Thu, 06/26/2008 - 17:38
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Looking at your configuration, here is what I would change:


1) Upgrade the boot loader to 4.2.112

2) Disable Ethernet Multicast unless you are using it.

3) Add the secondary DHCP 130.0.1.128 to the AP-Manager interface (for consistency)

4) Remove the DHCP override on the bcmh profile. It is pointing to a DHCP server of 130.0.0.60

5) Disable WMM unless you have IP phones

6) bcmh is configured for WEP, so verify the client is setup correctly.


That is all for now. Hope this helps.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode