sccp to sip in uc500

Answered Question
Jun 20th, 2008
User Badges:

Dear all,


I am trying to make a sip call from uc500 to ASTRIK which iam connected to it throw site to site vpn.


i was doing somthing stupied by trying to dial from my 7940 phone without change it to sip ..i have tried alot of cisco guides to convert 7940 to sip but nothing worked out may be its the UC500.. attached is my running config ..


in my phone when i check status from Network configuration i have VERSION 8.0(5.0)

i follow this link http://www.cisco.com/univercd/cc/td/doc/product/voice/its/cmeadm/cmeinstl.htm#wp1070512

and do every step to change SCCP to SIP

but nothing work out... i dont know if i need to downgrade from SCCP 8.x to 5.x then upgrade to sip 4.x ... and is the firmware in call manager same as call manager express or uc500


Correct Answer by paolo bevilacqua about 9 years 1 month ago

There is nothing you can do about on the UC500.


You are calling 618 correctly but asterisk replies that it doesn't know this number.


It's up to them to fix the problem. Unfortunately often people using "free" solutions don't really know how to do things.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Fri, 06/20/2008 - 11:13
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


you don't need the 7940 to be converted to SIP in order to call from UC500 to asterisk and vice-versa. Cisco phones work better in SCCP when used with CME.UC/CCM, etc.


Let us know what you want to do exactly and we can give you indications how to do that.

motasemkhater Sat, 06/21/2008 - 11:59
User Badges:

I have a site to site vpn , in my LAN i have UC500 and in other site there is a Asterisk with sip server i can ping this server , i want to register with this server so i can call there extentions, for test i have 7940 in my site with ext 618 and in the Asterisk site they have 277 ext , so i make dial-peer 3001 and sip-ua configuration and open all ports in my WAN port


please check my running configuration



Attachment: 
paolo bevilacqua Sat, 06/21/2008 - 13:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, do "debug ccsip message" with "term mon" to see why the call is failing. If it is a registration problem, remove the registration from asterisk (recommended), or configure sip-register under sip-ua so that extension will also register to asterisk.





motasemkhater Sat, 06/21/2008 - 21:36
User Badges:

ok sir i ll try it and give you my feed back today, but i what do u mean by [remove the registration from asterisk (recommended)] and how to do it


and there is no command sip-register under sip-ua ??

paolo bevilacqua Sun, 06/22/2008 - 02:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I meant, configure asterisk so that no registration is required.

I was referring to the registrar server command.

motasemkhater Sun, 06/22/2008 - 02:59
User Badges:

Hi Sir,

I cant get yoyr point ,!!

my customer is the one that have Asterisk and want me to give him a Cisco solution , by connection to Asterisk Sip server so he can call Asterisk site ,


They have done a test using Linksys and sip phones and every thing work fine with them .


we offer the uc500 solution .


first is this doable?

second what i understand till now that the UC500 will register with sip server (astersik) and allow calls to sip users .

is that right ?


all configuration that i have made is the sip-ua and dial -peer ,, what else i need sir


dial-peer voice 3001 voip

destination-pattern 277

session protocol sipv2

session target ipv4:192.168.253.35

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

no dial-peer outbound status-check pots

sip-ua

authentication username xxx password xxx

sip-server ipv4:192.168.253.35

ashok_boin Sun, 06/22/2008 - 07:12
User Badges:
  • Bronze, 100 points or more

Hi,


If your goal is to communicate between your SCCP phones (Cisco callmanager) & SIP phones (Asterisk), then you just need to create SIP trunk interaces to your SIP proxy server in Cisco callmanager. And CCM will take care of signaling conversion.


No need to convert your phone signaling to SIP.


Please follow this link...


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/4_0_1/ccmsys/a08sip.html


Regards...

-Ashok.

paolo bevilacqua Sun, 06/22/2008 - 10:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ashok, he is using CME, not CM, so the link provided does not apply.


However the logic is correct (configure sip trunk). Then if doesn't work you have to find why with "debug ccsip message" and "term mon".

ashok_boin Sun, 06/22/2008 - 21:49
User Badges:
  • Bronze, 100 points or more

Oh ok. I thought he was talking about Unified communications manager 5.0. Anyways, thanks for the correction.


Regards...

-Ashok.

paolo bevilacqua Mon, 06/23/2008 - 02:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


you get:

Received:

SIP/2.0 404 Not Found

Via: SIP/2.0/UDP 192.168.253.35:5060;branch=z9hG4bK0489;received=192.168.0.121

From: "618" ;tag=12AF0C-18C6

To: ;tag=as1b41f6e1


This means asterisk doesn't know anything about number 277. Configure asterisk accordingly.


motasemkhater Mon, 06/23/2008 - 04:10
User Badges:

thanks sir ,, i have check ith them and they call my ext,,and give them SIP/2.0 400 Bad Request - 'Invalid Host' comming from the Cisco


this the debug :-


14:05:08.641785 IP (tos 0x68, ttl 252, id 223, offset 0, flags [none], proto: UDP (17), length: 474) 192.168.0.121.5060 > 192.168.253.35.5060: SIP, length: 446

SIP/2.0 400 Bad Request - 'Invalid Host'

Via: SIP/2.0/UDP 192.168.253.35:5060;branch=z9hG4bK3effce61;rport

From: "Emmanuel Sovaridis" ;tag=as32434bc0

To: ;tag=996CA8-20E

Date: Mon, 23 Jun 2008 12:02:17 GMT

Call-ID: [email protected]

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=100

Content-Length: 0


paolo bevilacqua Mon, 06/23/2008 - 04:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please take the complete "debug ccsip mesage" also for incoming call.

Note DP 3001 should have codec g711u, not g771a, and also "incoming called-number ."

motasemkhater Mon, 06/23/2008 - 05:06
User Badges:

ok .. here is my sh run and the debug ...thank you very much


i just want to be sure that we dont need in sip-ua (register command or using dns not ip )


please check my sh run i did what you asked about DP, and incoming called number



Attachment: 
paolo bevilacqua Mon, 06/23/2008 - 05:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, asterisk is calling 192.168.0.121 but there is no such address configured in CME. Configure asterisk to so that call is sent to a valid address configured in CME.


Also do you have NAT between asterisk and CME ? NAT is always cause of big problems in voip.



motasemkhater Mon, 06/23/2008 - 05:46
User Badges:

sit , the fastethernet have 192.168.0.121 and it's an ip from lan ... i want to remmber you that there is site sto site vpn between 192.168.0.1 and 192.168.253.x,,, so we can ping it ...


about nat in uc500 ther is nat inside in VLAN 1, Vlan 100 ...and NAT outside on fastethernet ...so every thing want to get out go NATED through 192.168.0.121(FA) and go to 192.168.0.1 .. which can access 192.168.253.0 be site to site vpn


Is there problem with this nat?

I dont think they have to open ports to voice and data vlan in cme

paolo bevilacqua Mon, 06/23/2008 - 05:50
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, your FA0/0 uses DHCP so you cannot be sure that if gets 192.168.0.121. You need to use static addresses for SIP trunking, or registration.


About NAT, as long packets are NOT natted when going in the VPN, all is fine.


paolo bevilacqua Mon, 06/23/2008 - 06:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sorry, that is not possible. I answer questions freely on the forum only, all other forms of communication are reserved to my customers.

motasemkhater Mon, 06/23/2008 - 06:07
User Badges:

so what can we do know .. ish there any debug or anything you want to check??


and here is some debug from astersik sip..



Attachment: 
paolo bevilacqua Mon, 06/23/2008 - 07:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, send output of "show protocols" to prove that 192.168.0.121 is a valid address on the UC520.

motasemkhater Mon, 06/23/2008 - 23:25
User Badges:

JDStest#sh protocols

Global values:

Internet Protocol routing is enabled

FastEthernet0/0 is up, line protocol is up

Internet address is 192.168.0.121/24

Integrated-Service-Engine0/0 is up, line protocol is up

Interface is unnumbered. Using address of Loopback0 (10.1.10.2)

FastEthernet0/1/0 is up, line protocol is down

FastEthernet0/1/1 is up, line protocol is down

FastEthernet0/1/2 is up, line protocol is down

FastEthernet0/1/3 is up, line protocol is down

FastEthernet0/1/4 is up, line protocol is down

FastEthernet0/1/5 is up, line protocol is down

FastEthernet0/1/6 is up, line protocol is down

FastEthernet0/1/7 is up, line protocol is up

FastEthernet0/1/8 is up, line protocol is down

Vlan1 is up, line protocol is up

Internet address is 192.168.10.1/24

Vlan100 is up, line protocol is up

Internet address is 10.1.1.1/24

NVI0 is up, line protocol is up

Interface is unnumbered. Using address of NVI0 (0.0.0.0)

Loopback0 is up, line protocol is up

Internet address is 10.1.10.2/30

JDStest#


paolo bevilacqua Tue, 06/24/2008 - 00:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

OK, the debug now still show the same "invalid host" ?

motasemkhater Tue, 06/24/2008 - 23:40
User Badges:

IT's OFFICIAL NOW .. I LOVE Cisco and HATE the OTHERS......


so yesterday night i get a call from my customer and Asterisk cann call UC500..


the thing they changed ,, they restart there SIP server !!!!!!!!!!!!!!!!


so this is steps to connect SIP server with UC500


1- Listen to p.bevilacqua (cause he told me its there problem from reply 3 )


2- Always Ask the Others to RESTART there Equibment..

and every thing will work...


sorry p.bevilacqua.. i think its the longest conversation in Forum ;)..

any way there is a last issue if you can help , that we CAN'T call from UC500 to Asterisk ,,do you have any suggestion please .

paolo bevilacqua Wed, 06/25/2008 - 01:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, do not worry, it happens often that it takes a long time to fix problems and then is not even cisco problem.


Now for when uc500 calls asterisk, is the debug message still the same as before - "404 not found" ?

Correct Answer
paolo bevilacqua Wed, 06/25/2008 - 03:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

There is nothing you can do about on the UC500.


You are calling 618 correctly but asterisk replies that it doesn't know this number.


It's up to them to fix the problem. Unfortunately often people using "free" solutions don't really know how to do things.

motasemkhater Wed, 06/25/2008 - 03:43
User Badges:

ok thanks again SIR,


But iam 618 and trying to call 277 .. you know that right ..

Actions

This Discussion