Unity - Opening Greeting always playing

Unanswered Question
Jun 23rd, 2008


I have Unity set up in a failover configuration, (4.0.5), using exchange as the message store. I recently had to fail over to the secondary server and when I placed test calls into subscribers extensions, Unity played the Opening Greeting for all calls. Also, when calling from a subscribers phone, I heard the Opening Greeting when I should have heard the login conversation. Both the primary and secondary servers are setup to mirror eachother so I'm perplexed as to why this is happening only on the secondary server. Does anyone have any suggestions?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tommer Catlin Mon, 06/23/2008 - 07:28

Sounds like your replication is not working. When Unity can not find a subscriber or has an error, it will usually default to the opening greeting. This is by design. You can open up the Port Monitor and watch the call come into Unity, if it can not find the Subscriber it will most likely show that in the monitor.

Also make sure it really is going to failover server. I know in 4.05 there a lot of issues with failover. I have had many headaches trying to resolve issues around failover and this version and early.

Check your event log on both servers.

When in failover mode, open up the SA on the failover server.... do you see the subscribers?

Worst case, you will have to uninstall Failover on each server, reboot, then reinstall the failover wizard.

ranpierce Mon, 06/23/2008 - 07:36

This is for sure not message store issue.

First question I have is has this worked before. Is this a new installation?

If you go to Start > Programs > Unity > Call Viewer, can you make a test call and get a screen shot for me?

My guess is Call Manager is not sending the call information to Unity Secondary. That would be a config issue.

I can help once we figure out the problem.


askraydotcom Mon, 06/23/2008 - 07:38

Yes, this has worked before many, many times. I will try to do the call viewer to get an example. I am not using a Cisco Call Manager for the pbx, rather an NEC 2400 IMX.

ranpierce Mon, 06/23/2008 - 08:00

Is this a serial integration? If so get a sceenshot of the seral packet in commserver\IntegrationMonitor.exe


Tommer Catlin Mon, 06/23/2008 - 08:08

yeah, sounds like your DTMFs stopping going to the failover server. When the call hits the failover server, Unity does not know what to do with it, so it plays the default Opening Greeting then. Check your integration and like ran said, your serial integration.

You can also verify when in Failover Mode, hit the message button on the phone that worked on the Primary Unity server and received "enter your password then #" If it just plays the default Opening Greeting, you could have an integration problem.


This Discussion