TFTP Error - Path cannot be null

Answered Question
Jun 23rd, 2008

HI

I am trying to save the running config of a 515e PIX to a tftp server. I connect to the PIX using ASDM 5.0

I have set up the TFTP options, interface inside, ip address 172.16.10.9 (my pc), path - /TFTP-Root/ and I have install solarWinds tftp service, on my computer. but I keep getting the following error

ERROR] copy /noconfirm running-config tftp://172.16.10.9/TFTP-Root/test

Cryptochecksum: xxx

!!!!

%Error writing tftp://172.16.10.9/TFTP-Root/test (Path cannot be null.

Parameter name: path)

Can you tell me what I am doing wrong?

I have this problem too.
0 votes
Correct Answer by michael.leblanc about 8 years 7 months ago

I would try:

tftp://172.16.10.9/test

... the TFTP server know's what its own root directory is.

You should only need to specify the host and the destination file name.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Pravin Phadte Mon, 06/23/2008 - 08:52

Hi,

Its probably the '-'. Try to copy it to your tftp root directory by not putting in a path or just putting in the root dir. I would say just use the root dir for tftp and try again.

Hope this helps,

regards,

Pravin

mohammed_moustafa Tue, 06/24/2008 - 00:23

Hi all,

yes Mic, this is right we don't need to specify the path the tftp solar winds or any other application knows it's path.

B.ragards.

jasoned1969 Tue, 06/24/2008 - 00:54

Thanks guys, when I went to save the config, the root was already in there, so I was adding the file name on to the end. I have just tried saving the config again, but I removed the root first this time, then enter the file name only and it worked

Actions

This Discussion