SIP traffic through firewall

Unanswered Question
Jun 23rd, 2008

I Have a PABX Siemens in my inside network, and I need access this PABX with the SIP Protocol, but it does not work. I'm redirect all ip traffic from the ip xxx.xxx.xxx.149 to PABX IP, and setup all ACL's to permit.

My firewall is a CISCO asa 5510, ASA version 8.0(3).

anybody can help me?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Farrukh Haroon Thu, 06/26/2008 - 08:48

Have you tried to permit all IP traffic from one IP phones IP address to the back (and vice versa)? To see what ports are utilized.

Regards

Farrukh

Farrukh Haroon Thu, 06/26/2008 - 09:07

So it should work then? You permitted all IP traffic, howcome it won't work!

Have you tried toggling the sip inspection on/off?

Regards

Farrukh

gilbertojardim Thu, 06/26/2008 - 10:33

Yes... a already tried toggling the sip inspection on/off, but don't work. The IP phone success register on SIP server, but on the calling is muted on two points...

nomair_83 Mon, 06/30/2008 - 03:20

Dear can u increase the timeout of sip and sip media.

Regards,

Daniel Voicu Mon, 07/07/2008 - 03:00

You'll find here a very good document for configuring Voice over ASA

http://cisco.com/en/US/customer/products/ps6120/products_configuration_example09186a008081042c.shtml

Probably what happens is that even if you have SIP inspection, the NAT will not translate IP in the embedded data in the SIP packets.

You probably need to enable STUN service on the SIP PBX. STUN is used to detect NAT and will ensure correct IP information is sent in the SIP payload.

Please rate if this helped.

Regard,

Daniel

gilbertojardim Mon, 07/21/2008 - 03:55

I'm solved this problem changing the version of ASA software, from 8.0(2) to 7.2.4. After changed this software version, the SIP communication has be worked successful.

Actions

This Discussion