Duplex mismatch

Unanswered Question
Jun 23rd, 2008


I have this weird scenario:

I have 2 cisco switches connected using a cross cable

C3560 FA0/22 <-> C2950 FA0/24

Both ports have configured to be in full duplex, 100 mbps mode. However, recently, I see messages that complain that duplex mismatch. The problem was resolved by resetting the duplex to auto on both sides.

Jun 24 09:11:08: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/24 (not full du

plex), with JDAP_DEV_FS1 FastEthernet0/22 (full duplex).

Details of switch configurations:

Current configuration : 133 bytes


interface FastEthernet0/24

description Computer Room-Rack2 JDAP_DEV_FS1 X.X.X.X f0/22

switchport mode trunk

speed 100


Current configuration : 118 bytes


interface FastEthernet0/22

description To Computer Room-Rack2 JDAP_DEV_FS1_ES4 x.x.x.x fa0/24

speed 100


Switch version:

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4a, RELEASE SOFTWARE (fc1)

Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(25)SEB2, RELEASE SOFTWARE (fc1)

Anyone has any idea what can I do further to isolate the cause?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
glen.grant Mon, 06/23/2008 - 18:08

Hardcode both sides as the following and it should get rid of the message. Between cisco switches leaving them as auto for both speed and duplex will work fine also . If you don't specify the duplex it will usually default to half duplex .

speed 100

duplex full

benson.low Mon, 06/23/2008 - 18:12

Hi Glen,

Sorry, that my question has confused you. The configurations that you have seen are the modified ones. Previously, both sides have been hardcoded to be in speed 100, full duplex.

glen.grant Mon, 06/23/2008 - 18:18

It may be getting getting confused by the fact that you have one side hardcoded as a trunk and the other side is a access port .


This Discussion