After upgrade Unity to 5.01 SA Web unable to create subscriber

Unanswered Question
Jun 24th, 2008

The message store is off-box. After upgrade from Unity 4.04SR1 to 5.01, we are unable to create subscribers in SA Web. The radio button is grayed out.

Event log shows AvDCGC service can not connect to DC

The test result by the DCGC reconnect tools are good, Ping netbios name or full name are OK between unity and AD

And before the upgrade, unity 4.04sr1 is working fine

Can anyone help ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
shikamarunara Tue, 06/24/2008 - 15:12


After the upgrade, did you run the Permissions Wizard and the Unity Message Store Configuration Wizard? If services can not come up, it may be because your Unity System's AD and Exchange account are inaccessible.


dennis.kwok Tue, 06/24/2008 - 21:55

Shikamaru, I did Permissions Wizard and the Unity Message Store Configuration Wizard.

All services (Av....) are UP.

MWI, message left and retrieved are also OK, but delay.



shikamarunara Wed, 06/25/2008 - 08:17

So, did the Permissions Wizard and Unity Message Store Configuration Wizard fix the issue or was it something else?


Tommer Catlin Wed, 06/25/2008 - 08:47

Sounds like you need to use the grantunityaccess command. It did not set for some reason. Or your COS is not working properly.

Running the permissions wizards. I believe there is a new on at

shikamarunara Wed, 06/25/2008 - 08:57

Yeah, whenever you see grayed field like that, verify the setting on your COS.


dennis.kwok Thu, 06/26/2008 - 00:48

Dear All,

Actually, I ran the permisssion wizard which downloaded from ciscounitytools for unity upgrade.

When I put the mouse's pointer on the Add or delete button (they are grayed out) it shows the message " The Domain Controller for cannot be contacted. Add is temporarily not allowed "

The DC tested by DCGC tools are OK

Adding subscriber is OK before the upgrade, it implies the COS is also OK before the upgrade.



Tommer Catlin Thu, 06/26/2008 - 07:19

Go through your DNS and make sure all server names are resolving correctly. DNS could be your culprit here.

dennis.kwok Thu, 06/26/2008 - 07:56

Hi Tcatlinins,

I can not directly access DNS servers

But I have tested OK by ping to / from unity to DC by netbios name or full name.



Tommer Catlin Thu, 06/26/2008 - 07:57

was there a schema update run correctly for the install? Possibly the schema did not update correctly in the domain?

dennis.kwok Thu, 06/26/2008 - 08:02

Hi Tcatlinins,

I am sure that the schema update prompted me 100% successful



Tommer Catlin Thu, 06/26/2008 - 08:04

I would check the event log on the unity server then for Windows. See if you have any errors and let us know.


dennis.kwok Thu, 06/26/2008 - 08:16

Event reported by CiscoUnity_DSAD ( event ID 1017) , it says it can not communicate DC ......



dennis.kwok Sun, 07/06/2008 - 20:05

Dear All,

Thanks your advices.

With the help from TAC, it was fixed by manually removed one of DC by the DCGC tools.

But it is strange that the setting in DCGC tools is same for Unity 4 and 5. (it was kept same during the upgrade)



dennis.kwok Mon, 02/16/2009 - 18:59

Tac opened DCGC tool, he found there is a spare in front of domain controller entry, just delete the spare to fix the problem


dennis.kwok Mon, 02/16/2009 - 19:00

Sorry it should be " space " not spare

Tac opened DCGC tool, he found there is a space in front of domain controller entry, just delete the space to fix the problem


dennis.kwok Wed, 02/18/2009 - 00:21

Hi Dave,

DC and GC are detected auto by the tool by default

manually add the DC and GC.

Before unity 5.01 , DC and GC were manually added, after upgrade to unity 5.01, there was a "space" in front of DC (DC was maunally added) just delete the space, it was fixed



This Discussion