RIPv2 on Catalyst 4948

Answered Question
Jun 24th, 2008

Hello,

I've got to be missing something simple here. I have two Catalyst 4948 about 15 miles apart, connected via dark fiber. They both have base IP image.

I've been configuring RIP(version 2) to route between the switches. Static routes work fine, but when I use RIP, neither switch shows any of the routes.

The fiber is plugged into a port on each switch that is in the same VLAN.

Here's what I have configured:

Switch 1:

router rip

version 2

redistribute connected

redistribute static

Switch 2:

router rip

version 2

redistribute connected

redistribute static

network x.x.x.x

no auto-summary

I've also tried this on the vlan interface for both sides:

interface vlanxxx

ip rip send version 2

ip rip receive version 2

Like I said, I've got to be missing something simple here.

Thanks in advance for any feedback.

Lewis

Correct Answer by Edison Ortiz about 8 years 8 months ago

Switch 1 needs a network statement to enable RIP on the interface.

network statement should be of the Vlan being shared by this inter-switch link.

You may also include no auto-summary on that switch as well.

HTH,

__

Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Edison Ortiz Tue, 06/24/2008 - 05:06

Switch 1 needs a network statement to enable RIP on the interface.

network statement should be of the Vlan being shared by this inter-switch link.

You may also include no auto-summary on that switch as well.

HTH,

__

Edison.

Lewis Benton Tue, 06/24/2008 - 05:23

Thanks Edison,

That did the trick. I also had the wrong network statement on switch 2. Once I added that to it, Switch 2 got the routes via RIP.

Thanks again,

Lewis

Actions

This Discussion