×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Gatekeeper and CAC control for g729r8 call

Unanswered Question
Jun 24th, 2008
User Badges:

Hello,


When I place a call from ucme to ucm through a gk, I get a busy tone and I receive an ARJ on the cucm trunk side.


My initial outbound voip dp hqs no codec configured (default is g729r8).


I configured GK CAC to get 96 kbits (6 x g729 calls) over the WAN.


If I remove bandwidth command in GK, call is ok. If I configured bandwidth to 128, call is ok. 127 is not ok. So, I suppose GK sees my call has a g711 call on the cucm trunk side.



Any idea ? An IOS issue with 12.4(15T)?

I also put the codec in hard in the initial outbound dp.


Regards,

Guillaume

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rchilcote Tue, 06/24/2008 - 09:09
User Badges:
  • Bronze, 100 points or more

Guillaume,


Make sure you're matching the right outbound DP in CME by using the debug voip dialpeer command. Also try to put the CUCM trunk in a device pool with a region that only allows g729 calls. Are the CUCM and CME in the same local zone in GK or do you have multiple local zones?


gboulle Wed, 06/25/2008 - 03:48
User Badges:

Here are some extra output.


HQ is GK in headquater

BR2 is remote site.


I placed a call from 3001 (br2) to 1001 (HQ).


In CUCM config :

CUCM trunk is in another DP from HQ devices and inter region codec is set to g729.


CUCM and CME are in the same local zone.


HQ#sh gatekeeper calls

Total number of active calls = 1.

GATEKEEPER CALL INFO

====================

LocalCallID Age(secs) BW

1-21153 16 128(Kbps)

Endpt(s): Alias E.164Addr

src EP: GW-UCME 3002

CallSignalAddr Port RASSignalAddr Port

10.102.12.254 1720 10.102.12.254 57066

Endpt(s): Alias E.164Addr

dst EP: ICT-trunk_1 1#1001

CallSignalAddr Port RASSignalAddr Port

10.100.12.2 49929 10.100.12.2 49928




HQ#sh run | se gatek

snmp-server enable traps gatekeeper

gatekeeper

zone local UCM lab.local 172.1.100.1

zone prefix UCM 1* gw-priority 10 ICT-trunk_1

zone prefix UCM 1* gw-priority 0 GW-UCME

zone prefix UCM 2* gw-priority 10 ICT-trunk_1

zone prefix UCM 2* gw-priority 0 GW-UCME

zone prefix UCM 34*

zone prefix UCM 3* gw-priority 10 GW-UCME

zone prefix UCM 3* gw-priority 0 ICT-trunk_1

no shutdown


BR2#sh run | se dial-peer voice 202

dial-peer voice 202 voip

corlist outgoing lock-internal

preference 1

destination-pattern ^[12]...$

session target ras

tech-prefix 1#

dtmf-relay h245-alphanumeric

no vad


1/xxxxxxxxxxxx/DPM/dpMatchPeers:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=202



HQ#debug gatek main 10

HQ#

Jun 25 11:35:54.605: gk_rassrv_arq: arqp=0x862DDAC4, crv=0x4D, answerCall=0

Jun 25 11:35:54.605: gk_rassrv_sep_arq: ARQ Didn't use GK_AAA_PROC

Jun 25 11:35:54.605: gk_dns_query: No Name servers

Jun 25 11:35:54.605: rassrv_get_addrinfo: (1#1001) Matched tech-prefix 1#

Jun 25 11:35:54.605: rassrv_get_addrinfo: (1#1001) Matched zone prefix 1 and remainder 001

Jun 25 11:35:54.605: gk_rassrv_get_ingress_network: ARQ non-std ingress network = 1

Jun 25 11:35:54.609: rassrv_arq_select_viazone: about to check the source side, src_zonep=0x8624CDC0

Jun 25 11:35:54.609: rassrv_arq_select_viazone: matched zone is UCM, and z_invianamelen=0

Jun 25 11:35:54.609: rassrv_arq_select_viazone: about to check the destination side, dst_zonep=0x8624CDC0

Jun 25 11:35:54.609: rassrv_arq_select_viazone: matched zone is UCM, and z_outvianamelen=0

Jun 25 11:35:54.609: gk_rassrv_get_ingress_network: ARQ non-std ingress network = 1

Jun 25 11:35:54.629: gk_process: QUEUE_EVENT (minor 0) wakeup

Jun 25 11:35:54.633: gk_rassrv_arq: arqp=0x863D4B74, crv=0x804D, answerCall=1

Jun 25 11:35:54.633: gk_rassrv_dep_arq: ARQ Didn't use GK_AAA_PROC

Jun 25 11:35:55.166: gk_process: QUEUE_EVENT (minor 0) wakeup

Jun 25 11:35:57.085: gk_process: got a TIMER event



Maybe I miss something in the config ?


Regards,

Guillaume


rchilcote Wed, 06/25/2008 - 04:36
User Badges:
  • Bronze, 100 points or more

The config looks good. What do the statistics say on the phones as to what codec is being used? If your dial-peer is set to 729 and the CUCM trunk region is 729, I don't see how 711 is being negotiated. If the phones say that 729 is being used then my guess is that there is some bug pertaining to the gatekeeper BW.


If 711 is somehow being negotiated by the phones, then I'd say that maybe the call is always failing when matching dial peer 202 (or on the CUCM side with 729) and then trying another dial peer that has 711 as the codec.


Do you have the MTP checkbox checked on the GK trunk in CUCM? If so keep in mind that a SW MTP cannot be used with the 729 codec.


Let me know if you find the problem.

mciarfello Fri, 06/27/2008 - 20:05
User Badges:
  • Silver, 250 points or more

Check your CCM traces. Make sure your ICT-trunk_1 got matched for your incoming call and make sure as previously indicated that it is negotiating g.729.

Actions

This Discussion