Bridging VLANs

Unanswered Question
Jun 24th, 2008
User Badges:

I am working through an MPLS network that doesn't support VPLS. I have a question related to how I can bridge VLANs between two sites using my switches connected to the providers MPLS network. I believe that DLSw will be able to bridge the traffic on a per-VLAN basis using bridge-groups, but I wanted to know if this method would be discouraged.


My endpoint switches are a ME6524 and C6503 going into the providers network.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
william.caban Tue, 06/24/2008 - 07:10
User Badges:


I have never done it, but, if using the bridge-group approach, what about GRE tunnels?


Anyway, I would recommend L2TPv3 (but I don't think there is an IOS version for the C6503 which supports it). In the C7600 IOS 12.2(33)SRC and above supports it. You may also use the 1800, 2800, 3800, 1700, 2600XM.


If you are running MPLS over the MPLS service, with the C6500 you may try pseudowires/xconnect with mpls encapsulation.



-W

mmarchuk Wed, 06/25/2008 - 06:27
User Badges:

That's the plan I'm taking at this point...pseudowires with MPLS encapsulation. I'll let you know how it goes!


Michael

jander2008 Wed, 06/25/2008 - 08:18
User Badges:

Hi Mike:


Can you also post your configs once you get it to work?


Thx.


JD

shivlu jain Thu, 06/26/2008 - 00:23
User Badges:
  • Silver, 250 points or more

either you can use the mpls or l2tpv3.


pseudowire-class tulip

encapsulation l2tpv3/mpls

ip local interface Loopback0

end


interface GigabitEthernet x.x

encapsulation dot1Q 419

xconnect 419 encapsulation l2tpv3/mpls pw-class tulip

end



regards

shivlu




mmarchuk Thu, 06/26/2008 - 05:24
User Badges:

OK, well my platforms (6503 / 6524) and IOS limit the choices I have available to me for the pseudowire configuration.


I have the following that looks "right" but doesn't ever get to an "UP" condition when I do a "show mpls l2transport summary".


On the 6503 (PE1):

interface GigabitEthernet3/1

description Customer VLAN Access - Site 1 (CUST1)

no ip address

no cdp enable

!

interface GigabitEthernet3/1.123

encapsulation dot1Q 123 native

ip vrf forwarding Customer1

ip address 11.11.11.1 255.255.255.252

no cdp enable

!

interface GigabitEthernet3/1.999

description Layer2 Customer Interface

encapsulation dot1Q 999

no cdp enable

xconnect 4.0.0.2 501 encapsulation mpls

!



On the CE:


interface FastEthernet0/1

description Customer #1 outbound interface

switchport access vlan 123

switchport trunk encapsulation dot1q

switchport trunk native vlan 123

switchport trunk allowed vlan 123,999

switchport mode dynamic desirable

no ip address

duplex full

speed 100

!

interface Vlan123

ip address 11.11.11.2 255.255.255.252

!

interface Vlan999

ip address 5.5.5.1 255.255.255.0

!



mmarchuk Thu, 06/26/2008 - 05:33
User Badges:

Here is the destination PE config:


PE2:


!

interface GigabitEthernet1/21.999

description Layer 2 Customer

encapsulation dot1Q 999

xconnect 4.0.0.1 501 encapsulation mpls

!


sh mpls l2transport vc


Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Gi1/21.999 Eth VLAN 999 4.0.0.1 501 DOWN





On the PE1 switch:

sh mpls l2transport vc


Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Gi3/1.999 Eth VLAN 999 4.0.0.2 501 DOWN






william.caban Mon, 06/30/2008 - 14:55
User Badges:

Are you sure the CE port is operating in trunk mode? Have you tried forcing switchport mode to trunk?


There are certain features on the 6500 that actually work only if the port is in a SIP200/400/600 interface. But, even in those cases the xconnects will be up.


From the output seems is not coming up at all.


Are there labels for the 4.0.0.x destinations?


Can you do the "sh xconnect all" command? You should see Local UP and Remote DOWN.


-W

Actions

This Discussion