ANI server is down

Unanswered Question
Jun 25th, 2008
User Badges:

whenever I try to connect Campus Manager, I got that problem


Campus Manager Error

Cannot connect to ANI Server


Problem Cause: ANI server is down


How can I verify that ANI server is running? moreover that, where can I see what servers are down and what servers are ok?

by the way, I use CW LMS 3.0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
yjdabear Wed, 06/25/2008 - 06:14
User Badges:
  • Gold, 750 points or more

Look for ANIServer in the output of /opt/CSCOpx/bin/pdshow.

serdarkose Wed, 06/25/2008 - 23:35
User Badges:

I run pdshow.cmd it shows server status thank u. could u tell me how to start ANIServer pls ?

Surya Dathan Thu, 06/26/2008 - 00:57
User Badges:

You may stop and start this two services in service.msc


1. CiscoWorks Daemon Manager

2. CiscoWorks ANI database engine


It will bring up after a while.


Hope this help.

serdarkose Thu, 06/26/2008 - 06:23
User Badges:

thanks for ur suggestion but it does not work.


I got the process status from common services > server > reports

it says that ANIServer has shut down by administrator. I have not shut down any services? could anyone pls tell me where do I start ANIServer ?

eliaspaulos Thu, 06/26/2008 - 09:52
User Badges:

use this command if you are on solaris.


restart ANI server

/opt/CSCOpx/bin/pdterm ANIServer

/opt/CSCOpx/bin/pdexec ANIServer


Eli

serdarkose Thu, 06/26/2008 - 22:30
User Badges:

I use Windows 2003 but I run pdterm and pdexec in the bin direction but ANIServer's status is still down, I run the all .cmd .exe and .bat extension file but ANIServer does not work. does anyone know how to run ANIServer?

Martin Ermel Fri, 06/27/2008 - 02:50
User Badges:
  • Blue, 1500 points or more

first: never start any of the CiscoWorks processes/services from the service panel of windows (services.msc) or change their default startup settings unless you are adviced to do so (e.g by Cisco TAC)


for stopping and starting all the LMS processes use the following CLI command:

net stop crmdmgtd

net start crmdmgtd


if LMS processes are running, you can check their status from CLI with:

pdshow (to get a list of all processes)

pdshow (to get the status of a single process -case sensitive-)


if ANIServer is down, you can start it with

pdexec ANIServer


this can only be successfull if the following processes are also running (ANIServer depends on them)

EDS

ANIDbEngine


I hope you have not really run all .cmd .exe and .bat extension files under NMSROOT\bin ... (NMSROOT is the installation directory - defaults to: C:\Program files\CSCOpx)


I think currently it would be best trying to shutdown LMS (net stop crmdmgtd) which could take up to 10 mins, after this completes, do a server reboot. This should restart all LMS processes. Login into LMS around 15 mins after the reboot and try to launch Campus. If it is still not working, wait another 10 mins before retrying. If it will be unsuccessfull please post the output of pdshow (as an attachment).


serdarkose Fri, 06/27/2008 - 05:41
User Badges:

thanks for ur reply, it is really helpful but I still can not start device discovery under campus manager because it says ANI Server may down


I typed pdshow ANIServer and I get those

Process = ANIServer

State = Running with busy flag set

Pid = 11064

RC = 0

Signo = 0

Start 27.06.2008 14:48:55

Stop = Not applicable

Core = Not applicable

Info = ANIServer started



pdshow EDS

Process = EDS

State = Running normally

Pid = 4380

RC = 0

Signo = 0

Start 27.06.2008 14:35:14

Stop = Not applicable

Core = Not applicable

Info = Initialization complete



pdshow ANIDbEngine


Process = ANIDbEngine

State = Program started - No ögt ösgs received

Pid = 1620

RC = 0

Signo = 0

Start = N/A

Stop = Not applicable

Core = Not applicable

Info = Service was already running


why does ANIServer runs with busy flag set, how can I manage ANIServer run normally? thank u

eliaspaulos Fri, 06/27/2008 - 06:04
User Badges:

ANIServer runs with busy flag is per Cisco it's normal, mine also always like that.did you restart your server? with my experience restarting process or daemon manager is not effective always at least for me. I used restart

as my last resort.

serdarkose Fri, 06/27/2008 - 06:45
User Badges:

yes I had restart the server and I again did it. I got the same output when I type pdshow ANIServer. I can not use device discovery, I reach it from this directory admin> device discovery > discovery settings

I click "jump router boundaries" then click on "apply" but I got this error message:


Speed Device Exception Message: Exception in connecToCampusServer()

Speed Device Exception Message: Can not start device discovery, ANI Server may be down


Do u have any ide what the problem is ?

Martin Ermel Fri, 06/27/2008 - 07:01
User Badges:
  • Blue, 1500 points or more

How long have you waited after the reload of the server until you tried to launch Campus?


please post the following log:

NMSROOT/MDC/tomcat/logs/stdout.log

serdarkose Fri, 06/27/2008 - 10:07
User Badges:

I have waited 15 or 20 min to reach after restart the server. I am at home right now, I'll be at the work on monday, so I can post it on monday:( thanks for ur all help

serdarkose Sun, 06/29/2008 - 22:51
User Badges:

I have attached the stdout.log

I am trying to use Campus Manager Device Discovery but I can not use it.



Attachment: 
serdarkose Sun, 06/29/2008 - 23:25
User Badges:

Whenever I try to reach SNMP settings from admin> Device Discovery > SNMP settings

I got this error

" SNMP Exception Message: Exception in connectToCampusServer() . "


then I add a snmp setting and I click to "OK" button but I got an error. I have attached that error window.

does anyone know how to solve that problem ?



Attachment: 
Martin Ermel Mon, 06/30/2008 - 00:11
User Badges:
  • Blue, 1500 points or more

please check if casuser (member of the group 'casusers') is still a valid user on your system.

If it is, stop dmgtd (net stop crmdmgtd) and execute the script

NMSROOT\setup\support\resetCasuser.exe


Start dmgtd again and try to launch Campus.


serdarkose Mon, 06/30/2008 - 01:15
User Badges:

I stoped and runed Casuser.exe , next I changed the password, then started crmdmgtd but I got the same errors which I had before. I could not find where I can see casusers group. Is it done on Internetwork Performance Monitor > Collector Mgmt > Group Administration > User Defined Groups ? how will I add casuser ?

Martin Ermel Mon, 06/30/2008 - 04:02
User Badges:
  • Blue, 1500 points or more

casuser is a *windows* user that was added when you have installed CiscoWorks and it is used internaly. So you need to check if this users exists as a windows user on your LMS server. Also check if the group 'casusers' has full permissions on C:\Program Files\CSCOpx and the subdirectories.


Actions

This Discussion