Spanning tree issue

Unanswered Question
Jun 25th, 2008

I have 3550 with Version 12.1(22)EA4

Which I have Rapid spanning tree and a switch set as spanning-tree vlan 1 priority 4096


When I configure this

interface range Gi0/1 -2

!

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1

switchport nonegotiate

no shut

!

switchport trunk native vlan 2

!

network goes into a loop.

When I look at spanning tree there are switches with the wrong root switch

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kevin Dorrell Wed, 06/25/2008 - 23:22

Did you set the native VLAN 2 at the other end of the link? If you do not do that, you will get problems. The best way to do it is to change the native VLAN while the port is down, then bring the port up once both ends of the link are changed.


You will also get a problem with this config if the other end of the link is CatOS. Recent IOS is OK with the situation where the native is not on the allowed list. CatOS does not handle it correctly (due to a bug) and the Spanning-Tree breaks down. The bug was fixed in later IOS versions, but was never fixed in CatOS.


Kevin Dorrell

Luxembourg


jfeo Wed, 06/25/2008 - 23:27

problem is I am doing this remotely. This is a project I have 200 sites with 9 switches at each site

I have to change the configuration and reboot all switches

So we are looking at a IOS bug is there any docs on that

Kevin Dorrell Wed, 06/25/2008 - 23:44

The IOS version of the bug is CSCed00396, which is available on the bug toolkit. It was first found in 12.1(19)EA1. What puzzles me is that it was supposed to have been fixed by 12.1(22)EA2. Do you have the more recent version at both ends?


For the CatOS version, I can tell you the bug number - CSCdv19761 - but it seems to be Cisco restricted.


Kevin Dorrell

Luxembourg







jfeo Wed, 06/25/2008 - 23:52

all with that IOS


I have some sites with 3560 ios 12.2(37)SE1 mixed in with the 3550


Kevin Dorrell Wed, 06/25/2008 - 23:54

Maye it is not what I think then. But the symptoms are remarkably similar. If you allow the native VLAN (2) on the trunk (at both ends) does the problem still happen?


Kevin Dorrell

Luxembourg

jfeo Wed, 06/25/2008 - 23:56

if I put this on the problem goes away


switchport trunk allowed vlan 1 ,2

Kevin Dorrell Thu, 06/26/2008 - 00:34

Then I would contend that it is the same bug. Maybe the versions in the bug database are wrong. Could you ask TAC about it?


I suggest either you include VLAN 2 in the trunk (which is what I did to overcome the problem), or you update the IOS.


Kevin Dorrell

Luxembourg


Actions

This Discussion