Bookmarks on clientless SSL VPN

Unanswered Question
Jun 25th, 2008
User Badges:

I've configured a portal page with a bookmark for a cifs connection to a server. The bookmark shows up okay, but is greyed out and not clickable. I found some info pointing to DNS, citing that the URL must be resolvable via DNS, but I'm using an IP address so that shouldn't be an issue. Any ideas?


portion of the config below


group-policy TestingGroupPolicy internal

group-policy TestingGroupPolicy attributes

banner value This is a test

vpn-tunnel-protocol webvpn

webvpn

url-list value ClientlessSSLVPNBookmark

filter value FileTransferWebACL

customization value FileTransfer


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Farrukh Haroon Thu, 06/26/2008 - 00:30
User Badges:
  • Red, 2250 points or more

What is your 'functions' command.



Regards


Farrukh

David Niemann Fri, 06/27/2008 - 05:51
User Badges:

Is that valid for 8.x code? I forgot to mention that I'm running 8.0.2

clausonna Tue, 07/01/2008 - 09:06
User Badges:
  • Bronze, 100 points or more

Make sure your CIFS URL includes '\\' for the server.


If you're trying to connect to the share "data" on server "testsvr1", then in the URL field you need to specify:


\\testsvr1\data


So the URL is going to look like cifs://\\testsvr1\data


If you get prompted for credentials then you need to enable single signon.

clausonna Wed, 07/02/2008 - 09:45
User Badges:
  • Bronze, 100 points or more

Replying to my own post here.


You need to make sure you have dns enabled for your inside interface, so it can resolve the name of the server:

dns domain-lookup Inside


The cifs://testsvr1\data worked on my 8.0(3)19 box, but not on my straight 8.0(3) ASA. I wound up getting the following to work:


cifs://testsvr1/data


Actions

This Discussion