WIC-1ENET DSL Major Speed Decrease

Unanswered Question
Jun 25th, 2008
User Badges:

Hello,


Don't have a clue what could have happened, but my DSL slowed way down on me about a week and a half ago, and it got trouble shot back to 2 components....my DSL modem was bad, and my 1751 router would not obtain anywhere near full speed (600Kbps - 2.5Mbps out of a 10Mbps Link). I pop my old linksys back on after replacing the modem and getting erratic good speeds to provider (5-8Mbps), but slow (1Mbps) to outside world, and all of a sudden I get the full 10Mbps link and everything works fine. Also my ping time between the two to the same server was constant 19 with linksys and 43 with cisco.


Haven't changed any config. The MTU's and everything is all the same, not to mention it was working just fine for me before. maybe WIC-1ENET card got damaged? Is there a way to tell without having a spare?


Thank you,

Mark


Config attached.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Thu, 06/26/2008 - 07:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, there is no conceivable way a card can be damaged so to cause bad performances. You can check show interface for errors, but that's it.


Likely the problem lies elsewhere...

sandman420 Fri, 06/27/2008 - 07:35
User Badges:

let me start out by saying that i am by no means a networking or cisco guru, however i do have a pretty extensive networking background going back about 10-12 years, and for the last 5 have been working in the field as a communications service technician for a PBX/Key system company servicing voice and data networks. So i do know stuff. I do admit I am very new to Cisco (figured i better start learning), and have only taught myself enough to know how to program this 1751 up for PPPoE login DSL connection through my wic-1enet, SSH 1.5, VPN server, DHCP server, and port forwarding.


well, process of eliminations concludes that the cisco 1751 is at fault. now, whether or not this is due to hardware faults or programming (comms params), i don't know. I do know that nothing has physically nor logically changed on the network anytime relatively close to the event occurring.


What i can tell you is that my dsl modem was replaced due to failure, which brought the already erratic slow speeds of 600K-2.5Mbps up to 3-6.5Mbps (connection from my equip to service providers), however the connection from me to my provider, then out to the internet and back was still only 600K-1Mbps. I did a "show int e 0/0" and "show int dialer 1" and no errors on either. I borrowed a spare wic-1enet card from work and tried popping it in. Both eth 0/0 and dialer 1 interfaces came up, but the dialer handling the PPPoE login session had no communication. Again, no errors on show int. I tried changing the MTU on int dialer 1 from its default 1500 to 1492 like my linksys had set, and still no difference. Everything works great when wan is connected to the linksys router though. I get my full 10Mbps connection, which I had previously not been able to get (even once they turned it up in the area-was only 8Mbps before). And that's the thing, even when the cisco was working great before, it never got up to the full 10Mbps once the speed was turned up here.


Is anyone willing to look at my config or maybe do some troubleshooting with me?

paolo bevilacqua Fri, 06/27/2008 - 10:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


The router is configured Ok. Only, you need "ip tcp mess-adjust 1452" under interface fa0/0 and not under any other interface.



sandman420 Fri, 06/27/2008 - 13:43
User Badges:

yeah, i think i saw that under show int on the ethernet 0/0 interface as well. i would just issue "no ip tcp mess-adjust" under that interface, then add it to my fasteth 0/0? what does this command do, and why only on the LAN side?


Thank you

paolo bevilacqua Fri, 06/27/2008 - 13:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes. Since you have PPPoE with a reduced MTU, it is needed to avoid receiving packets too big that could be dropped. Command goes on the input interface facing client, and modifies the value seen by the server.

sandman420 Fri, 06/27/2008 - 15:04
User Badges:

actually after looking, both eth 0/0 and dialer 1 interfaces had the ip tcp adjust-mss 1452 on them and the fasteth 0/0 did not.


So to get thi absolutely correct...the default values for those adjust-mss fields are wrong and i need to issue "no ip tcp adjust-mss" to both eth 0/0 and dialer 1, and i need to issue "ip tcp adjust-mss 1452" to the fasteth 0/0 interface?


thank you for your patience.

paolo bevilacqua Fri, 06/27/2008 - 15:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, as mentioned you need it only on the intf. facing PCs, that is FA0/0.

This may or may not fix the performance issue, let us know.



Actions

This Discussion