n.nandrekar Wed, 06/25/2008 - 23:46

hi!

You can "erase start" from previliged mode and restart the switch. It will bootup with default config.


Regards,

Niranjan

serdarkose Thu, 06/26/2008 - 00:05

thanks for ur reply,


I wrote "erase start" on EXEC mode then I entered "reload". After that switch's SYST link has been flushing(green) for 5 minutes, I dont understand what's wrong, I have unpluged and pluged the power cord, but syst link is still flushing and the switch does not work:( could u tell me what to do?


nnandrek Thu, 06/26/2008 - 00:53

What does the console say? What output do you have on the console/ Is it stuck in ROMMON or something? Can you paste the consoe output?


Regards,

Niranjan

serdarkose Thu, 06/26/2008 - 01:13

I think I am stuck in ROMMON but I am not sure, when I connect the switch with console port, only "switch:" is written on the console.

when "?" is entered those output comes


switch: ?

? -- Present list of available commands

boot -- Load and boot an executable image

cat -- Concatenate (type) file(s)

copy -- Copy a file

delete -- Delete file(s)

dir -- List files in directories

flash_init -- Initialize flash filesystem(s)

format -- Format a filesystem

fsck -- Check filesystem consistency

help -- Present list of available commands

load_helper -- Load and initialize a helper image

memory -- Present memory heap utilization information

mkdir -- Create dir(s)

more -- Concatenate (display) file(s)

rename -- Rename a file

reset -- Reset the system

rmdir -- Delete empty dir(s)

set -- Set or display environment variables

set_bs -- Set attributes on a boot sector filesystem

set_param -- Set system parameters in flash

sleep -- Pause (sleep) for a specified number of seconds

-- MORE --

trap -- Cause a software breakpoint to occur

type -- Concatenate (type) file(s)

unset -- Unset one or more environment variables

version -- Display boot loader version




when I unplug the power cord then I push the mode button and plug the power cord, after a certain time this output is appeared


switch:

Base ethernet MAC Address: 00:1e:f6:58:1d:00

Xmodem file system is available.

The password-recovery mechanism is enabled.


The system has been interrupted prior to initializing the

flash filesystem. The following commands will initialize

the flash filesystem, and finish loading the operating

system software:


flash_init

load_helper

boot


I have never seen this commands before, could u tell me the next step?

n.nandrekar Thu, 06/26/2008 - 01:01

if the switch is stuck in "Rommon " mode when you see through the console, probably it is not finding the boot image. See with dir slot0: or dir bootdisk: and once you get the image name, say boot bootdisk: or boot slot0:imagename depending on where the image is located.


Regards,

Niranjan

serdarkose Thu, 06/26/2008 - 01:34

I typed

switch: dir slot0

unable to stat slot0/: no such device


switch: dir


List of filesystems currently registered:


flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)


switch: boot bootdisk:flash (and tried with xmodem and null)

Loading "bootdisk:flash"...bootdisk:flash: no such device


Error loading "bootdisk:flash"


Interrupt within 5 seconds to abort boot process.

Boot process failed...


switch: help boot

Usage for "boot" is:

boot [-n|-j] [-p] [-c] [-f] [-i] [-m] [-notnd] [-notni] [-post] [-skip_post]

[-reserve_mem <1-15>] [-no_esp_keepalive] []



I dont know what to do now, could u tell me what should I do ?

thank u so much for your helps

glen.grant Thu, 06/26/2008 - 03:13

Do a "dir flash: and see if there is any image in there. If there is issue a "boot flash: command and see if it will boot other wise you will have to go thru a image recovery procedure . Doing what you did would not have erased the image file , someone else would have had to erase the file while it was powered up and you were the unlucky person who tried to erase the config.

serdarkose Thu, 06/26/2008 - 03:22

I did it

switch: dir flash:

Directory of flash:/


32513024 bytes available (1024 bytes used)


there is no any image file. so what do I have to do ? I think I need to download 2960 IOS and load to switch, do u know where can I download 2960 IOS

n.nandrekar Thu, 06/26/2008 - 04:47

hi!

You woul need a cisco.com login to download the image from under "software downloads" on the cisco main page.


Regrads,

Niranjan

Correct Answer
n.nandrekar Thu, 06/26/2008 - 06:15

Hi!

Can you please mark the issue as solved?

Regards,

Niranjan

Actions

This Discussion