"ip ospf mtu-ignore" is ...ignored

Unanswered Question
Jun 26th, 2008
User Badges:
  • Silver, 250 points or more

Hello all!


I have a "stupid" situation.OSPF process between 2 interfaces with different MTU values and of course the EXSTART/EXCHANGE stuck situation.

I put "ip ospf mtu-ignore" and I worked fine until yesterday, when one of the interfaces went down.After a shut / no shut, the OSPF process remained stuck in EXSTART/EXCHANGE. I tried to re-apply the "ip ospf mtu-ignore", then all the settings still the same result.If I set the MTU manually to the same values in both sides than everything is ok.

Does any of you encounter this behavior for "ip ospf mtu-ignore"? The platform which is having problems is a C6509 with IOS 12.2(33)SXH

Thanks!


Br,

Calin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Kevin Dorrell Thu, 06/26/2008 - 04:26
User Badges:
  • Green, 3000 points or more

I suspect that the mtu-ignore is actually working. If you debug the OSPF, what do you see?


I suspect what is happening here is that the sides have different MTU, and one side is producing OSPF LSAs that are too big for the other side. Are you seeing an giants on your interface counters?


Kevin Dorrell

Luxembourg


Calin Chiorean Thu, 06/26/2008 - 04:55
User Badges:
  • Silver, 250 points or more

On the router where I suspected that mtu-ignore is not working i have:

OSPF: Rcv DBD from 172.31.1.237 on Tunnel911 seq 0x1426 opt 0x52 flag 0x7 len 32 mtu 1427 state EXCHANGE

OSPF: Send DBD to 172.31.1.237 on Tunnel911 seq 0x1426 opt 0x52 flag 0x2 len 1452


On the other router:

Jun 26 12:47:31 UTC: OSPF: Send DBD to 172.31.0.1 on Tunnel911 seq 0x1426 opt 0x52 flag 0x7 len 32

Jun 26 12:47:31 UTC: OSPF: Retransmitting DBD to 172.31.0.1 on Tunnel911 [9]


If you will look at the first debug, you will see that the router receive packets with MTU 1427.The second router will not receive anything because the MTU of the router with "mtu-ignore" problem is 9135, so it will be discarded.

So that's why I think that the "mtu-ignore" is not working.I do not have giants.


Maybe you should know that this C6500 had some problems in the past (e.g. I inserted a NAM module and the chassis crashed) and maybe it need some special troubleshoot like...reload :)).


Thanks for answer!

Actions

This Discussion