udld

Unanswered Question
Jun 26th, 2008

I have 3560 with 12.2.37 se1 connnected via

fiber to 3550 with 12.1.22.ea4

I am enabling udld aggressive

as soon as i enable this my fiber ports go into error disble

before I enable this everything looks good on the interface no errors

Anybody seen this issue

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rpratapa Thu, 06/26/2008 - 11:18

You need to configure udld in aggressive mode on the other switch as well. In udld aggressive mode, the switch expects to receive a "valid reply message" ( sort of hello) from the other switch within a specific period of time. If this does not happen, the port id "disabled"

Hope this helps

-rk

jfeo Thu, 06/26/2008 - 11:22

thanks for the reply I do have it configurd on the other switch

but I still get the error disable

is there a way to adjust the time

jfeo Thu, 06/26/2008 - 11:31

No just on one usually the 3560

and when I do reset udld goes right back to error disable

what is the time limit

rpratapa Thu, 06/26/2008 - 11:37

It appears that 3560 is not receiving the "valid reply" from 3550 and that is the reason it's port is being "disabled".

Are the fiber strands OK? properly connected?

-rk

francisco_1 Thu, 06/26/2008 - 11:47

what udld aggressive mode does is, it will make eight attempts to re-establish the UDLD neighbor relation before error disabling the port if the 3560 is not receiving any responses from the 3550.

The last time this happened to me was a faulty sfp on my 3560.

Couple of things to check

Try replacing your fiber cable if that does not help try another port.

Also you might what to disable udld and enable udld debug event / packet before enabling udld again to see what the problem might be.

Good luck.

jfeo Thu, 06/26/2008 - 11:51

Thanks I replaced patch cables same thing

might be a bad gbic hope not

when I have a bad gbic I find symbols errors which I don't see

jfeo Thu, 06/26/2008 - 11:58

this is from debug

%UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Gi0/2, unidirectional link detected

%PM-4-ERR_DISABLE: udld error detected on Gi0/2, putting Gi0/2 in err-disable state

%udld_linkchange called, reason = link, new_link_state = down, cookies = 1

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down

%LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down

francisco_1 Thu, 06/26/2008 - 11:58

try to replace the gbic and see what happens...

also make sure both switches not negotiating speed. issue "speed nonegotiate"

jfeo Thu, 06/26/2008 - 12:13

wow thank you very much

speed nonegotiate worked

Actions

This Discussion