1812W->one dhcp->wifi+LAN

Unanswered Question
Jun 27th, 2008

hi there!

scenario same as here

http://cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805e7a23.shtml

but with LAN connected to the router too.

How do I do it with dhcp server on the router and wifi and LAN?

Purpose is to obtain address from DHCP to Wifi and also LAN.

my existing config is as below, but WiFi can't get IP address from DHCP server on the router...

vlan 1

authentication open

guest-mode

!

no ip source-route

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool test1

import all

network 192.168.0.0 255.255.255.0

default-router 192.168.0.253

domain-name ct.local

!

!

no ip bootp server

no ip domain lookup

ip domain name ct.local

ip name-server 62.87.178.194

ip name-server 10.0.0.4

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

username nieca privilege 15 secret xxx

!

!

archive

log config

hidekeys

!

!

ip tcp synwait-time 10

!

!

!

interface Null0

no ip unreachables

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Dot11Radio0

no ip address

!

ssid cisco

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

!

ssid cisco

!

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

ip address 192.168.0.253 255.255.255.0

!

no ip forward-protocol nd

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 07/01/2008 - 10:55

Grzegorz

If you want to have a single pool of addresses and have the router act as DHCP server using that single pool of addresses for both the wireless and the LAN then there are several things that you will need to change.

As currently configured the DHCP pool serves only the LAN, since the address is configured on the VLAN 1 interface and there is nothing to associate the wireless with that address space. So you will need to change this.

One way to think about it is that if the router will need to act as DHCP server for both the LAN and the wireless then they both need to be in the same broadcast domain (right now they form separate broadcast domains). So you should configure IRB as the easy way to put both the LAN and the wireless into the same broadcast domain.

Start with

bridge irb

bridge 1 route ip

Then in interface VLAN 1 remove the IP address and configure bridge-group 1. With bridge-group 1 on both the LAN and the wireless they will be in the same broadcast domain. Configure interface bvi 1 and assign the IP address to the BVI.

That should get both the LAN and the wireless into the same broadcast domain and allow the router to assign addresses from the same pool to end stations on the LAN and on the wireless.

HTH

Rick

tomaszpopik Wed, 10/29/2008 - 04:01

Thank you Rick, i have sucessfully configured 1812W following your advice.

LAN, WAN, WIFI, IP SLA.

Actions

This Discussion