Can't get vlan trunking to work

Unanswered Question
Jun 27th, 2008
User Badges:

Okay I'm running a wsc2950c-24 switch and a 3640 router from cisco. And I follow the instructions they have on their site and I just can't get this thing to work prooperly.


The computer on Vlan 1 has an ip of 192.168.4.100. The computer on vlan 85 has an ip of 192.168.5.101. I can't get 5.101 to ping anything on the switch. But on 4.100 I can get it to ping both router addresses and the switch address.


My config files are below:


Switch:

Using 2263 out of 32768 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname swtmw-em-test1

!

enable secret 5 XXXX

enable password XXXXX

!

ip subnet-zero

!

vtp domain XXXXX

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 81

name johdoe

shutdown

!

interface FastEthernet0/1

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 81

!

interface FastEthernet0/4

switchport access vlan 81

!

interface FastEthernet0/5

switchport access vlan 81

!

interface FastEthernet0/6

switchport access vlan 81

!

interface FastEthernet0/7

switchport access vlan 81

!

interface FastEthernet0/8

switchport access vlan 81

!

interface FastEthernet0/9

switchport access vlan 81

!

interface FastEthernet0/10

switchport access vlan 81

!

interface FastEthernet0/11

switchport access vlan 81

!

interface FastEthernet0/12

switchport access vlan 81

!

interface FastEthernet0/13

switchport access vlan 81

!

interface FastEthernet0/14

switchport access vlan 81

!

interface FastEthernet0/15

switchport access vlan 81

!

interface FastEthernet0/16

switchport access vlan 81

!

interface FastEthernet0/17

switchport access vlan 81

!

interface FastEthernet0/18

switchport access vlan 81

!

interface FastEthernet0/19

switchport access vlan 81

!

interface FastEthernet0/20

switchport access vlan 81

!

interface FastEthernet0/21

switchport access vlan 81

!

interface FastEthernet0/22

switchport access vlan 81

!

interface FastEthernet0/23

switchport trunk allowed vlan 1-90

switchport mode trunk

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface Vlan1

ip address 192.168.4.253 255.255.255.0

no ip route-cache

!

interface Vlan81

no ip address

no ip route-cache

!

ip default-gateway 192.168.4.254

ip http server

banner login ^C kdkakfjakjdflkjasdlkfjakjdsfla C

dddddddddddddddddddddddddddddddddddddddddddddddddddddddddd^C

!

line con 0

line vty 0 4

password netAdm1n

login

line vty 5 15

password netAdm1n

login

!

!

end






router:

Using 1358 out of 129016 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rtrmw-em-test

!

enable secret 5 XXXXX

enable password XXXXX

!

ip subnet-zero

no ip routing

!

!

!

!

!

!

interface FastEthernet1/0

no ip address

no ip route-cache

speed auto

half-duplex

no mop enabled

!

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

ip address 192.168.4.254 255.255.255.0

no ip route-cache

!

interface FastEthernet1/0.2

encapsulation dot1Q 81

ip address 192.168.5.254 255.255.255.0

no ip route-cache

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password netAdm1n

login

!

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
cowetacoit Fri, 06/27/2008 - 06:37
User Badges:

you have NO IP ROUTING on your router....you must enable routing, "IP ROUTING"

lee.reade Fri, 06/27/2008 - 06:48
User Badges:
  • Silver, 250 points or more

Hi,


You dont have the IP address set on vlan 81, so how can the switch send traffic to/from this subnet, if it doensnt have a route for it?


Cheers,


LR

cowetacoit Fri, 06/27/2008 - 06:57
User Badges:

You have both of these configured for inter vlan routing. Try this config. Please look at the differences.





Using 2263 out of 32768 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname swtmw-em-test1

!

enable secret 5 XXXX

enable password XXXXX

!

ip routing

!

ip subnet-zero

!

vtp domain XXXXX

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 81

name johdoe

no shut

!

interface FastEthernet0/1

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 81

!

interface FastEthernet0/4

switchport access vlan 81

!

interface FastEthernet0/5

switchport access vlan 81

!

interface FastEthernet0/6

switchport access vlan 81

!

interface FastEthernet0/7

switchport access vlan 81

!

interface FastEthernet0/8

switchport access vlan 81

!

interface FastEthernet0/9

switchport access vlan 81

!

interface FastEthernet0/10

switchport access vlan 81

!

interface FastEthernet0/11

switchport access vlan 81

!

interface FastEthernet0/12

switchport access vlan 81

!

interface FastEthernet0/13

switchport access vlan 81

!

interface FastEthernet0/14

switchport access vlan 81

!

interface FastEthernet0/15

switchport access vlan 81

!

interface FastEthernet0/16

switchport access vlan 81

!

interface FastEthernet0/17

switchport access vlan 81

!

interface FastEthernet0/18

switchport access vlan 81

!

interface FastEthernet0/19

switchport access vlan 81

!

interface FastEthernet0/20

switchport access vlan 81

!

interface FastEthernet0/21

switchport access vlan 81

!

interface FastEthernet0/22

switchport access vlan 81

!

interface FastEthernet0/23

switchport mode access

switchport access vlan 1

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface Vlan1

ip address 192.168.4.253 255.255.255.0

no ip route-cache

!

interface Vlan81

ip address 192.168.5.254 255.255.255.0

no ip route-cache

!

ip route 0.0.0.0 0.0.0.0 192.168.4.254

ip http server

banner login ^C kdkakfjakjdflkjasdlkfjakjdsfla C

dddddddddddddddddddddddddddddddddddddddddddddddddddddddddd^C

!

line con 0

line vty 0 4

password netAdm1n

login

line vty 5 15

password netAdm1n

login

!

!

end






router:

Using 1358 out of 129016 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rtrmw-em-test

!

enable secret 5 XXXXX

enable password XXXXX

!

ip subnet-zero

ip routing

!

!

!

!

!

!

interface FastEthernet1/0

ip address 192.168.4.254 255.255.255.0

speed auto

half-duplex

no mop enabled


ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password netAdm1n

login

!

end

cowetacoit Fri, 06/27/2008 - 06:58
User Badges:

enable IP routing on the switch. Add IP to Interface vlan 84, set default route to the router, removed the sub interfaces of the router and assign it an ip. enable IP routing on the router as well.

Edison Ortiz Fri, 06/27/2008 - 07:03
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Gentlemen,


The switch is a L2 switch.


The original poster should continue with the configuration in the router as its L3 device.


IP Routing is disabled in the router and it should be enabled for inter-vlan routing.


Also, devices on each subnet must point to the L3 interface in the router that belongs on that subnet.


HTH,


__


Edison.

adambrandes Fri, 06/27/2008 - 11:30
User Badges:

This guy is right. I did all my config on the router and got it working. I did some stupid crap when I was configuring it and just reset it all.


Thanks for the help guys.

Actions

This Discussion